aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/smartgit')
-rw-r--r--dev-util/smartgit/ChangeLog6
-rw-r--r--dev-util/smartgit/smartgit-0_alpha4.ebuild44
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/smartgit/ChangeLog b/dev-util/smartgit/ChangeLog
index f79139bd3..39facaf97 100644
--- a/dev-util/smartgit/ChangeLog
+++ b/dev-util/smartgit/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*smartgit-0_alpha4 (17 Sep 2009)
+
+ 17 Sep 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +smartgit-0_alpha4.ebuild, -smartgit-0_alpha2_p2.ebuild:
+ version bump
+
*smartgit-0_alpha2_p2 (07 Sep 2009)
07 Sep 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/dev-util/smartgit/smartgit-0_alpha4.ebuild b/dev-util/smartgit/smartgit-0_alpha4.ebuild
new file mode 100644
index 000000000..7ed07cbfa
--- /dev/null
+++ b/dev-util/smartgit/smartgit-0_alpha4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-utils-2
+
+DESCRIPTION="SmartGIT"
+HOMEPAGE="http://www.syntevo.com/smartgit"
+SRC_URI="${PN}-generic-1-M4.tar.gz"
+
+SLOT="0"
+LICENSE="smartgit"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}"/smartgit-1-M4/
+
+pkg_nofetch(){
+ einfo "Please download ${MY_P}.tar.gz from:"
+ einfo "http://www.syntevo.com/smartgit/early-access.html"
+ einfo "and move/copy to ${DISTDIR}"
+}
+
+src_install() {
+ local rdir="/opt/${PN}"
+ insinto ${rdir}
+ doins -r * || die "cannot install needed files"
+
+ java-pkg_regjar "${D}"/${rdir}/lib/*.jar
+
+ java-pkg_dolauncher ${PN} --java_args "-Xmx256M -Dsmartgit.vm-xmx=256m" --jar ${PN}.jar
+
+ for X in 32 64 128
+ do
+ insinto /usr/share/icons/hicolor/${X}x${X}/apps
+ newins "${S}/bin/icon-${X}.png" "${PN}.png" || die "cannot install needed files"
+ done
+
+ make_desktop_entry "${PN}" "SmartGIT" ${PN}.png "Development;RevisionControl"
+}