aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild')
-rw-r--r--media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild b/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild
new file mode 100644
index 000000000..5389bcfcf
--- /dev/null
+++ b/media-gfx/PhiloGL/PhiloGL-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="WebGL Framework for Data Vis, Creative Coding and Game Development"
+HOMEPAGE="http://www.senchalabs.org/philogl/"
+SRC_URI="http://www.senchalabs.org/philogl/downloads/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+S=${WORKDIR}
+
+src_prepare() {
+ if use examples ; then
+ for f in $(find ${S}/examples -name index.html); do
+ sed -e "s:../../../build:/usr/share/${PN}:g" \
+ -e "s:../../build:/usr/share/${PN}:g" \
+ -i ${f} || die
+ done
+ sed -e "s:../../../shaders/:/usr/share/${PN}/shaders/:" \
+ -i examples/lessons/{14,15,16}/index.js || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r build/* shaders
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}