aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/librecad')
-rw-r--r--media-gfx/librecad/ChangeLog6
-rw-r--r--media-gfx/librecad/librecad-1.0.3.ebuild24
-rw-r--r--media-gfx/librecad/librecad-1.0.4.ebuild24
3 files changed, 21 insertions, 33 deletions
diff --git a/media-gfx/librecad/ChangeLog b/media-gfx/librecad/ChangeLog
index dfded7070..e719749de 100644
--- a/media-gfx/librecad/ChangeLog
+++ b/media-gfx/librecad/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-gfx/librecad
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header$
+ 15 Jan 2015; Marius Brehler <marbre@linux.sungazer.de>
+ librecad-1.0.3.ebuild, librecad-1.0.4.ebuild:
+ Move to EAPI=5
+
15 Jan 2015; Dongxu Li <dongxuli2011@gmail.com> +librecad-2.0.7.ebuild, -librecad-2.0.3.ebuild:
Version bump: 2.0.7
diff --git a/media-gfx/librecad/librecad-1.0.3.ebuild b/media-gfx/librecad/librecad-1.0.3.ebuild
index 8a04ca196..ae7b0ac37 100644
--- a/media-gfx/librecad/librecad-1.0.3.ebuild
+++ b/media-gfx/librecad/librecad-1.0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit qt4-r2 eutils
+inherit eutils qt4-r2 vcs-snapshot
DESCRIPTION="An generic 2D CAD program"
HOMEPAGE="http://www.librecad.org/"
@@ -19,27 +19,19 @@ RDEPEND="
dev-qt/qtgui[qt3support]
dev-qt/qthelp:4
dev-qt/qt3support:4
- dev-cpp/muParser
- "
+ dev-cpp/muParser"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- mv * ${P}
-}
-
src_prepare() {
-sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro"
+ sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro" || die
}
src_install() {
- dobin unix/librecad || die
+ dobin unix/librecad
insinto /usr/share/"${PN}"
- doins -r unix/resources/* || die
- if use doc ; then
- dohtml -r support/doc/*
- fi
+ doins -r unix/resources/*
+ use doc && dohtml -r support/doc/*
doicon res/main/"${PN}".png
make_desktop_entry "${PN}" LibreCAD "${PN}.png" Graphics
}
diff --git a/media-gfx/librecad/librecad-1.0.4.ebuild b/media-gfx/librecad/librecad-1.0.4.ebuild
index 8a04ca196..ae7b0ac37 100644
--- a/media-gfx/librecad/librecad-1.0.4.ebuild
+++ b/media-gfx/librecad/librecad-1.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit qt4-r2 eutils
+inherit eutils qt4-r2 vcs-snapshot
DESCRIPTION="An generic 2D CAD program"
HOMEPAGE="http://www.librecad.org/"
@@ -19,27 +19,19 @@ RDEPEND="
dev-qt/qtgui[qt3support]
dev-qt/qthelp:4
dev-qt/qt3support:4
- dev-cpp/muParser
- "
+ dev-cpp/muParser"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- mv * ${P}
-}
-
src_prepare() {
-sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro"
+ sed -i -e "s:\\\$\+system(git describe --tags):1.0.3:" "${PN}.pro" || die
}
src_install() {
- dobin unix/librecad || die
+ dobin unix/librecad
insinto /usr/share/"${PN}"
- doins -r unix/resources/* || die
- if use doc ; then
- dohtml -r support/doc/*
- fi
+ doins -r unix/resources/*
+ use doc && dohtml -r support/doc/*
doicon res/main/"${PN}".png
make_desktop_entry "${PN}" LibreCAD "${PN}.png" Graphics
}