aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/librecad/ChangeLog3
-rw-r--r--media-gfx/librecad/librecad-9999.ebuild21
2 files changed, 12 insertions, 12 deletions
diff --git a/media-gfx/librecad/ChangeLog b/media-gfx/librecad/ChangeLog
index c157115fb..f180d50a7 100644
--- a/media-gfx/librecad/ChangeLog
+++ b/media-gfx/librecad/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header$
+ 11 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> librecad-9999.ebuild:
+ media-gfx/librecad: Fixed bug #472472 and ebuild cleaning
+
8 Jun 2013; Dongxu Li <dongxuli2011@gmail.com> +librecad-2.0.0_rc1.ebuild:
Versions bumped to 2.0.0_rc1
diff --git a/media-gfx/librecad/librecad-9999.ebuild b/media-gfx/librecad/librecad-9999.ebuild
index d3db6f76e..ab66f2424 100644
--- a/media-gfx/librecad/librecad-9999.ebuild
+++ b/media-gfx/librecad/librecad-9999.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
-inherit qt4-r2 eutils git-2 flag-o-matic
+EAPI=5
+inherit qt4-r2 eutils git-2
-DESCRIPTION="An generic 2D CAD program"
+DESCRIPTION="Generic 2D CAD program"
HOMEPAGE="http://www.librecad.org/"
LICENSE="GPL-2"
SLOT="0"
@@ -26,17 +26,14 @@ DEPEND="${RDEPEND}
src_prepare() {
#sed -i -e "s:\\\$\+system(git describe --tags):9999:" src/src.pro
#enable C++11 by default
- sed -i -e '/RS_VECTOR2D/ s/^#//' librecad/src/src.pro
+ sed -i -e '/RS_VECTOR2D/ s/^#//' librecad/src/src.pro || die
}
-src_install()
-{
+src_install() {
dobin unix/librecad
- insinto /usr/share/"${PN}"
+ insinto /usr/share/${PN}
doins -r unix/resources/*
- if use doc ; then
- dohtml -r support/doc/*
- fi
- doicon librecad/res/main/"${PN}".png
- make_desktop_entry "${PN}" LibreCAD "${PN}" Graphics
+ use doc && dohtml -r librecad/support/doc/*
+ doicon librecad/res/main/${PN}.png
+ make_desktop_entry ${PN} LibreCAD ${PN} Graphics
}