aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild')
-rw-r--r--net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild b/net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild
index b7fcdc3fb..f065fe5e9 100644
--- a/net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild
+++ b/net-ftp/bbftp-server/bbftp-server-3.2.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit eutils
+
DESCRIPTION="bbFTP is a file transfer software. It implements its own transfer protocol, which is optimized for large files (larger than 2GB) and secure as it does not read the password in a file and encrypts the connection information."
HOMEPAGE="http://doc.in2p3.fr/bbftp/"
@@ -16,7 +18,9 @@ IUSE="ssl pam"
DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}"
-src_prepare() {
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${P}"
epatch "${FILESDIR}"/${PV}-deffixes.patch
}
@@ -25,7 +29,7 @@ src_compile() {
econf $(use_with ssl) $(use_with pam) --with-gzip \
--without-rfio \
--without-afs || die "configure failed"
- emake
+ emake || die "compile failed"
}
src_install() {