aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/libthesky')
-rw-r--r--sci-astronomy/libthesky/Manifest4
-rw-r--r--sci-astronomy/libthesky/libthesky-0.3.2.ebuild35
-rw-r--r--sci-astronomy/libthesky/libthesky-0.4.2.ebuild37
-rw-r--r--sci-astronomy/libthesky/metadata.xml4
4 files changed, 41 insertions, 39 deletions
diff --git a/sci-astronomy/libthesky/Manifest b/sci-astronomy/libthesky/Manifest
index 240414b04..aed369dea 100644
--- a/sci-astronomy/libthesky/Manifest
+++ b/sci-astronomy/libthesky/Manifest
@@ -1,2 +1,2 @@
-DIST libthesky-0.3.2.tar.gz 124598 BLAKE2B a70db5dea8aa7ce478a5eb5ac3a837e2580b90c4ede2539059c57033e90eee56f453ea4efc811795bbbad5896190d8455315b41e3b5e147650f0f3c8e2263b1a SHA512 64fae18cf410c37d6bda5d65f8890a045734fa3bbaa23c76a8080ef06e15443af5159baf779b69594e24bb1fc8b0719ba03174764d46abed66f61750e8e9e68e
-DIST libthesky-data-20131020.tar.bz2 3945800 BLAKE2B 317556d3f045fb154f692caa37d40001713ae382810edec9843685868facc89e90d74a01c4169232ffe765536e2c4a0504dd94be4ff01699d76069bb43f7f18e SHA512 2bbc2eaeb37a52f383625ecbb0c8d455741631b8cf212e5b8839a9d4276ca8bfc638087aca6d94a458e2889e8e0b9a37cd0392828fe24fb1f653d5956c27b27d
+DIST libthesky-0.4.2.tar.gz 217861 BLAKE2B 8197878a299b93e6c6f98aef5555bbbb4304ade0fff10714a4fb33cf6eac89ccd4ae24400f5ee0262dca877cf770e85525787ceca2b95700407ddd3f5fa5e133 SHA512 70bcc525d54f1645cff65fc0ac702fb0a19445d74fa3c567aa07fed027b966c4753146becb9efc46e81521d1788846c460c47ec88d6611cec0524c2dad7cb646
+DIST libthesky-data-20160409.tar.bz2 3780265 BLAKE2B 9331156f7536d634f8523e776209190d73c10158800ff73694ac499292b2be80948810e6aaa531b51d878b5018f7304188b855fcbc976a1b1c285829555d2f4e SHA512 b790aa70b60c6c35db85a54de3487aa5ef47710121cb6c6c13069d4d8adba822b61449eb59ce7ec9203fb4d9cf33570222ec9a65b36ac21f5d4506cddd0b35a3
diff --git a/sci-astronomy/libthesky/libthesky-0.3.2.ebuild b/sci-astronomy/libthesky/libthesky-0.3.2.ebuild
deleted file mode 100644
index 5a12fc708..000000000
--- a/sci-astronomy/libthesky/libthesky-0.3.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils fortran-2
-
-DESCRIPTION="Fortran library to compute positions of celestial bodies"
-HOMEPAGE="http://libthesky.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
-mirror://sourceforge/${PN}/libthesky-data-20131020.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-DEPEND=">=sci-libs/libsufr-0.5.4"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use static-libs CREATE_STATICLIB)
- )
- cmake-utils_src_configure
-}
-
-# Install the data files as well as the libraries:
-src_install() {
- insinto /usr/share/libTheSky
- doins "${WORKDIR}"/data/*
- cmake-utils_src_install
-}
-
-DOCS="CHANGELOG README VERSION"
diff --git a/sci-astronomy/libthesky/libthesky-0.4.2.ebuild b/sci-astronomy/libthesky/libthesky-0.4.2.ebuild
new file mode 100644
index 000000000..09f89265f
--- /dev/null
+++ b/sci-astronomy/libthesky/libthesky-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE=Release
+CMAKE_MAKEFILE_GENERATOR="emake"
+inherit cmake fortran-2
+
+DESCRIPTION="Fortran library to compute positions of celestial bodies"
+HOMEPAGE="http://libthesky.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/libthesky-data-20160409.tar.bz2
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sci-libs/libsufr[static-libs?]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ gunzip -r "${S}"/man || die
+ mv "${WORKDIR}"/data "${S}" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCREATE_SHAREDLIB=ON
+ -DCREATE_STATICLIB=$(usex static-libs)
+ )
+ cmake_src_configure
+}
diff --git a/sci-astronomy/libthesky/metadata.xml b/sci-astronomy/libthesky/metadata.xml
index 1ce9631c7..08c750857 100644
--- a/sci-astronomy/libthesky/metadata.xml
+++ b/sci-astronomy/libthesky/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>AstroFloyd@gmail.com</email>
- <name>AstroFloyd</name>
+ <email>git@vandersluys.nl</email>
+ <name>MarcvdSluys</name>
</maintainer>
<maintainer type="project">
<email>sci-astronomy@gentoo.org</email>