aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/psfex/psfex-9999.ebuild')
-rw-r--r--sci-astronomy/psfex/psfex-9999.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/sci-astronomy/psfex/psfex-9999.ebuild b/sci-astronomy/psfex/psfex-9999.ebuild
index 0e10198f7..db4df69be 100644
--- a/sci-astronomy/psfex/psfex-9999.ebuild
+++ b/sci-astronomy/psfex/psfex-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
if [[ ${PV} == "9999" ]] ; then
_SVN=subversion
@@ -14,7 +14,10 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit ${_SVN} autotools
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit ${_SVN} autotools-utils multilib
DESCRIPTION="Extracts models of the Point Spread Function from FITS images"
HOMEPAGE="http://www.astromatic.net/software/psfex"
@@ -23,7 +26,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc threads plplot"
-RDEPEND="sci-libs/atlas[lapack]
+RDEPEND="
+ sci-libs/atlas[lapack,threads=]
sci-libs/fftw:3.0
plplot? ( sci-libs/plplot )"
DEPEND="${RDEPEND}"
@@ -42,19 +46,25 @@ src_prepare() {
-e "s/-lcblas/-l${mycblas}/g" \
-e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
-e "s/-llapack/-l${myclapack}/g" \
+ -e "s/\(lapack_lib=\).*/\1${myclapack}/g" \
-e "s/AC_CHECK_LIB(lapack/AC_CHECK_LIB(${myclapack}/g" \
acx_atlas.m4 || die
- eautoreconf
+
+ # fix for newer plplot
+ sed -i -e 's/plcol(/plcol0(/g' src/cplot.c || die
+ autotools-utils_src_prepare
}
src_configure() {
- econf \
- --with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
- $(use_with plplot) \
+ local myeconfargs=(
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas"
+ $(use_enable plplot)
$(use_enable threads)
+ )
+ autotools-utils_src_configure
}
src_install () {
- default
+ autotools-utils_src_install
use doc && dodoc doc/*
}