aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stiff/stiff-9999.ebuild')
-rw-r--r--sci-astronomy/stiff/stiff-9999.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/sci-astronomy/stiff/stiff-9999.ebuild b/sci-astronomy/stiff/stiff-9999.ebuild
index 33c0767fd..6c70b1fb0 100644
--- a/sci-astronomy/stiff/stiff-9999.ebuild
+++ b/sci-astronomy/stiff/stiff-9999.ebuild
@@ -1,23 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit subversion
-#AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
+ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
-inherit autotools-utils
+SRC_URI=""
+KEYWORDS=""
DESCRIPTION="Converts astronomical FITS images to the TIFF format"
HOMEPAGE="http://astromatic.iap.fr/software/stiff"
@@ -32,12 +25,16 @@ RDEPEND="
sys-libs/zlib:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ subversion_src_prepare
+}
+
src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
+ econf $(use_enable threads)
}
src_install () {
- use doc && DOCS=( doc/. )
- autotools-utils_src_install
+ default
+ use doc && dodoc doc/*
}