aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/stuff')
-rw-r--r--sci-astronomy/stuff/ChangeLog10
-rw-r--r--sci-astronomy/stuff/Manifest3
-rw-r--r--sci-astronomy/stuff/files/stuff-configure.patch65
-rw-r--r--sci-astronomy/stuff/metadata.xml10
-rw-r--r--sci-astronomy/stuff/stuff-1.19.ebuild32
5 files changed, 120 insertions, 0 deletions
diff --git a/sci-astronomy/stuff/ChangeLog b/sci-astronomy/stuff/ChangeLog
new file mode 100644
index 000000000..86a4da28d
--- /dev/null
+++ b/sci-astronomy/stuff/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/stuff
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*stuff-1.19 (27 Jul 2009)
+
+ 27 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +stuff-1.19.ebuild,
+ +files/stuff-configure.patch, +metadata.xml:
+ Initial import
+
diff --git a/sci-astronomy/stuff/Manifest b/sci-astronomy/stuff/Manifest
new file mode 100644
index 000000000..4d2a5ef7c
--- /dev/null
+++ b/sci-astronomy/stuff/Manifest
@@ -0,0 +1,3 @@
+AUX stuff-configure.patch 1734 RMD160 cd80f40b8bf4757a7f30219a68393bc014dad63d SHA1 ba572bd637a09246ca2fcdb0f576ec183ce798b0 SHA256 7cdcd8b57aae0d2b80534794d3f9d34a72fde74e20cd6220f70e7d286fce11a9
+DIST stuff-1.19.tar.gz 4017086 RMD160 c8ac8d3bbe7cd4a7e48b81b98de60b6c777e6e74 SHA1 acf5b26e5cc10eac757b55b8cca59d5ca3d3ab94 SHA256 592e6bfff704d1391b150a0820b52258ef69a99b698ac07eb0a8f04daf5b0210
+EBUILD stuff-1.19.ebuild 695 RMD160 fc5184da3526c8931c1b56acda22a562a310978a SHA1 ef9d0e0163d94b1f4a08ffe9f18467b7b70023a0 SHA256 91f60a1e3e9751d9c1ba2de242bbc27e7783cd445bc082e1ec0009383ef8c753
diff --git a/sci-astronomy/stuff/files/stuff-configure.patch b/sci-astronomy/stuff/files/stuff-configure.patch
new file mode 100644
index 000000000..4f8c1bd63
--- /dev/null
+++ b/sci-astronomy/stuff/files/stuff-configure.patch
@@ -0,0 +1,65 @@
+--- configure.ac.orig 2009-03-25 18:21:24.000000000 +0000
++++ configure.ac 2009-03-25 18:27:33.000000000 +0000
+@@ -20,42 +20,17 @@
+ AC_SUBST(DATE3, "$date3")
+
+ # Include macros
+-sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_pthread.m4)
+ sinclude(acx_urbi_resolve_dir.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([******** Configuring: $PACKAGE_NAME $VERSION ($date) ********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-
+-# Backup and reset the input CFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-myldflags="$LDFLAGS"
+-LDFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AC_HELP_STRING([--enable-icc],
+- [Enable special mode for compilation with the Intel compiler \
+-(off by default)])],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+-
+ # Checks for programs.
+-# GCC is chosen last because it is likely to yield less optimized code
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C
+ AM_PROG_CC_STDC
+ # C Compiler: Check that it is POSIX-compliant
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+
+@@ -154,19 +129,6 @@
+ use_static="no"
+ fi
+
+-# Static linking option
+-if test "$use_static" = "yes"; then
+- LDFLAGS="-static -shared-libgcc $LDFLAGS"
+-fi
+-
+-# Override automatic CFLAGS and LDFLAGS with those of user
+-#if test -n "$mycflags"; then
+-#CFLAGS="$mycflags"
+-#fi
+-#if test -n "$myldflags"; then
+-#LDFLAGS="$myldflags"
+-#fi
+-
+ # Display compiler and linker flags
+ AC_MSG_RESULT([***************************************************************])
+ AC_MSG_RESULT([Compile cmdline: $CC $CFLAGS])
diff --git a/sci-astronomy/stuff/metadata.xml b/sci-astronomy/stuff/metadata.xml
new file mode 100644
index 000000000..11798a28a
--- /dev/null
+++ b/sci-astronomy/stuff/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Stuff is a program that simulates “perfect” astronomical
+ catalogues. It generate object lists in ASCII which can read by the
+ SkyMaker program to produce realistic astronomical fields.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/stuff/stuff-1.19.ebuild b/sci-astronomy/stuff/stuff-1.19.ebuild
new file mode 100644
index 000000000..eebbbae71
--- /dev/null
+++ b/sci-astronomy/stuff/stuff-1.19.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Tool for automatic generation of astronomical catalogs"
+HOMEPAGE="http://astromatic.iap.fr/software/sktuff/"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/stuff/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+}