aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/swarp/swarp-2.15.6.ebuild')
-rw-r--r--sci-astronomy/swarp/swarp-2.15.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/swarp-2.15.6.ebuild b/sci-astronomy/swarp/swarp-2.15.6.ebuild
new file mode 100644
index 000000000..359b2803e
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.15.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://terapix.iap.fr/soft/${PN}"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="static doc threads mpi icc"
+DEPEND="mpi? ( || ( sys-cluster/lam-mpi sys-cluster/mpich ) )
+ icc? ( dev-lang/icc >= 9 )
+ "
+# mpi stuff untested.
+src_compile() {
+ # trust swarp cflags to be optimized.
+ filter-flags ${CFLAGS}
+ # --disable-threads does not work
+ # note we could calculate a number of threads (~= ncpu)
+ local myconf=""
+ use threads && myconf="--enable-threads "
+ ! use mpi && export MPICC="gcc"
+ econf \
+ $(use_enable static ) \
+ $(use_enable icc ) \
+ $(use_enable mpi ) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING HISTORY README THANKS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*
+ fi
+}
+