aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/skymaker/ChangeLog9
-rw-r--r--sci-astronomy/skymaker/files/skymaker-configure.patch40
-rw-r--r--sci-astronomy/skymaker/skymaker-3.1.0.ebuild36
-rw-r--r--sci-astronomy/skymaker/skymaker-3.3.3.ebuild32
4 files changed, 80 insertions, 37 deletions
diff --git a/sci-astronomy/skymaker/ChangeLog b/sci-astronomy/skymaker/ChangeLog
index 189a83a4d..46454fbb5 100644
--- a/sci-astronomy/skymaker/ChangeLog
+++ b/sci-astronomy/skymaker/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for sci-astronomy/skymaker
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*skymaker-3.3.3 (27 Jul 2009)
+
+ 27 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -skymaker-3.1.0.ebuild, +skymaker-3.3.3.ebuild,
+ +files/skymaker-configure.patch:
+ Version bump
+
20 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org> ChangeLog:
Initial import
diff --git a/sci-astronomy/skymaker/files/skymaker-configure.patch b/sci-astronomy/skymaker/files/skymaker-configure.patch
new file mode 100644
index 000000000..7f7bdb1ba
--- /dev/null
+++ b/sci-astronomy/skymaker/files/skymaker-configure.patch
@@ -0,0 +1,40 @@
+--- configure.ac.orig 2009-03-25 18:16:52.000000000 +0000
++++ configure.ac 2009-03-25 18:17:35.000000000 +0000
+@@ -22,37 +22,18 @@
+
+ # Include macros
+ sinclude(acx_fftw.m4)
+-sinclude(acx_prog_cc_optim.m4)
+ sinclude(acx_pthread.m4)
+
+ # Display pakage and version number
+ AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
+
+-# Initialize the list of compilers to consider
+-cclist="cc gcc"
+-# Backup and reset the input CFLAGS
+-mycflags="$CFLAGS"
+-CFLAGS=""
+-
+-# Provide special option for the Linux Intel C compiler
+-AC_MSG_CHECKING([for Linux Intel C compiler mode])
+-AC_ARG_ENABLE(icc,
+- [AS_HELP_STRING(--enable-icc,Enable special mode for compilation with the Intel compiler \
+-(off by default))],
+- use_icc="yes"
+- cclist="icc $cclist"
+- AC_MSG_RESULT([yes]),
+- use_icc="no"
+- AC_MSG_RESULT([no]))
+
+ # Checks for programs.
+ # GCC is chosen last because it is likely to yield less optimized code
+ AC_LANG(C)
+-AC_PROG_CC([$cclist])
+ # C Compiler: Check that it is ANSI C and POSIX-compliant
+ AM_PROG_CC_STDC
+ AC_ISC_POSIX
+-ACX_PROG_CC_OPTIM
+ AC_DISABLE_STATIC
+ #AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
diff --git a/sci-astronomy/skymaker/skymaker-3.1.0.ebuild b/sci-astronomy/skymaker/skymaker-3.1.0.ebuild
deleted file mode 100644
index 5054b7e51..000000000
--- a/sci-astronomy/skymaker/skymaker-3.1.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Program that simulates astronomical images"
-HOMEPAGE="http://terapix.iap.fr/soft/skymaker"
-SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="threads mpi"
-RESTRICT="test"
-
-DEPEND=">=sci-libs/fftw-3
- mpi? ( virtual/mpi )"
-
-# mpi stuff untested.
-src_compile() {
- use mpi || export MPICC="$(tc-getCC)"
- local myconf
- # --disable-threads is buggy
- use threads && myconf="--enable-threads"
- econf \
- $(use_enable mpi) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
-}
diff --git a/sci-astronomy/skymaker/skymaker-3.3.3.ebuild b/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
new file mode 100644
index 000000000..95f431685
--- /dev/null
+++ b/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Program that simulates astronomical images"
+HOMEPAGE="http://astromatic.iap.fr/software/skymaker"
+SRC_URI="ftp://ftp.iap.fr/pub/from_users/bertin/skymaker/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND=">=sci-libs/fftw-3"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-configure.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
+}