aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/swarp/ChangeLog5
-rw-r--r--sci-astronomy/swarp/swarp-9999.ebuild17
2 files changed, 12 insertions, 10 deletions
diff --git a/sci-astronomy/swarp/ChangeLog b/sci-astronomy/swarp/ChangeLog
index 4c8d76b73..f5366c480 100644
--- a/sci-astronomy/swarp/ChangeLog
+++ b/sci-astronomy/swarp/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-astronomy/swarp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/swarp/ChangeLog,v 1.6 2011/08/04 18:33:44 bicatali Exp $
+ 27 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> swarp-9999.ebuild:
+ sci-astronomy/swarp: EAPI-5, autotools-utils
+
*swarp-9999 (04 Jul 2012)
04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +swarp-9999.ebuild,
diff --git a/sci-astronomy/swarp/swarp-9999.ebuild b/sci-astronomy/swarp/swarp-9999.ebuild
index c764e79b7..920850f65 100644
--- a/sci-astronomy/swarp/swarp-9999.ebuild
+++ b/sci-astronomy/swarp/swarp-9999.ebuild
@@ -2,19 +2,22 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
if [[ ${PV} == "9999" ]] ; then
_SVN=subversion
ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
SRC_URI=""
KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
else
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit ${_SVN} autotools
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit ${_SVN} autotools-utils
DESCRIPTION="Resample and coadd astronomical FITS images"
HOMEPAGE="http://astromatic.iap.fr/software/swarp"
@@ -27,16 +30,12 @@ IUSE="doc threads"
RDEPEND=""
DEPEND="${RDEPEND}"
-src_prepare() {
- eautoreconf
-}
-
src_configure() {
- econf \
- $(use_enable threads)
+ local myeconfargs=( $(use_enable threads) )
+ autotools-utils_src_configure
}
src_install () {
- default
+ autotools-utils_src_install
use doc && dodoc doc/*
}