aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/eye/eye-9999.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/sci-astronomy/eye/eye-9999.ebuild b/sci-astronomy/eye/eye-9999.ebuild
index bd822e78a..fc65a7185 100644
--- a/sci-astronomy/eye/eye-9999.ebuild
+++ b/sci-astronomy/eye/eye-9999.ebuild
@@ -1,23 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- _SVN=subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit subversion
-AUTOTOOLS_AUTORECONF=1
-#AUTOTOOLS_IN_SOURCE_BUILD=1
+ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
-inherit ${_SVN} autotools-utils
+SRC_URI=""
+KEYWORDS=""
DESCRIPTION="Enhance astronomical object extraction with neural network filters"
HOMEPAGE="http://www.astromatic.net/software/eye"
@@ -26,15 +19,22 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="doc threads"
-RDEPEND=""
+RDEPEND="
+ media-libs/tiff:0=
+ virtual/jpeg:0
+ sys-libs/zlib:0="
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ subversion_src_prepare
+}
+
src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
+ econf $(use_enable threads)
}
src_install () {
- autotools-utils_src_install
+ default
use doc && dodoc doc/*
}