aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/casapy-bin/ChangeLog7
-rw-r--r--sci-astronomy/casapy-bin/Manifest1
-rw-r--r--sci-astronomy/casapy-bin/casapy-bin-4.4.0.ebuild69
3 files changed, 76 insertions, 1 deletions
diff --git a/sci-astronomy/casapy-bin/ChangeLog b/sci-astronomy/casapy-bin/ChangeLog
index 8a563a78d..4ddfbd3e1 100644
--- a/sci-astronomy/casapy-bin/ChangeLog
+++ b/sci-astronomy/casapy-bin/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-astronomy/casapy-bin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*casapy-bin-4.4.0 (10 Aug 2015)
+
+ 10 Aug 2015; Joseph Jon Booker <joe@neoturbine.net> +casapy-bin-4.4.0.ebuild:
+ sci-astronomy/casapy-bin: version bump casapy-bin to 4.4.0
+
*casapy-bin-4.2.2.30986_p1 (09 Sep 2014)
09 Sep 2014; Joseph Jon Booker <joe@neoturbine.net>
diff --git a/sci-astronomy/casapy-bin/Manifest b/sci-astronomy/casapy-bin/Manifest
index c70a0dda5..eeee7bb9b 100644
--- a/sci-astronomy/casapy-bin/Manifest
+++ b/sci-astronomy/casapy-bin/Manifest
@@ -1,2 +1,3 @@
+DIST casa-release-4.4.0-el6.tar.gz 1028567130 SHA256 5c67dd31618b7125a57b4af828c717f5b3c8468d13b34d6fedccf8c5597bfa66 SHA512 ee71bd6d80c18db570f42e54d8d0d2d8cc512497ee885e316a81cc1f71480abb21681a8ef39991fe3673a70d036e1418a7f7d77909b3bc7ff2b32c8be004409f WHIRLPOOL 9087abb839f6d21b15ee363fcbf1e0794265881bf2948a498ce08210eebbb9ce0e976ee14f77fe591b85513a1d15d92fdf8b61ce438f26342418edcdfb16a772
DIST casapy-42.1.29047-001-1-64b.tar.gz 985311640 SHA256 966b86af4a09fc962b5eebd6b8679d686b5e811c17364e1350ea6c332f525ff0 SHA512 506a7d173a4196106d437ba234a48b186d036b82d524d89fbe476045de979992c438db12bcaa4eb42b551f1f9c65fd83fce3c7469a8c8ef60a4692d71bab40dc WHIRLPOOL 2e8b62f036fd4b822966954187f15ff5d247ac90a5e550bc94fb4102aade623526d14fc2edc843ca4a821bc26d5adfc89054f9190351e17d2ef10ba69b00454c
DIST casapy-42.2.30986-1-64b.tar.gz 1000907646 SHA256 e178b8005efeb9eee60f809f1eef6d55a5cd29b9b62b1a5a3103277635188f0c SHA512 2410b0e802752a1992a0add4cd23bd0f0dc9a0ca21895f1cd88ffb81ab5566b8bd1ff2c6c64759760105e65d0f844efa453b6ab52b2f86bc4017f5337fa66f5e WHIRLPOOL 340e99f95892a49b40ca1fb3da11110a99fda36f882b01de2cb9fee4c4f0b8609c07c46271d299146bbaeb1661aad18e409f2143f21be90f605e9e7a82e3d2cb
diff --git a/sci-astronomy/casapy-bin/casapy-bin-4.4.0.ebuild b/sci-astronomy/casapy-bin/casapy-bin-4.4.0.ebuild
new file mode 100644
index 000000000..f545ae23b
--- /dev/null
+++ b/sci-astronomy/casapy-bin/casapy-bin-4.4.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit versionator
+
+DESCRIPTION="Software package to calibrate, image, and analyze radioastronomical data"
+HOMEPAGE="http://casa.nrao.edu/"
+
+MY_P=${P/py-bin/-release}-el6
+SRC_URI="https://svn.cv.nrao.edu/casa/linux_distro/release/el6/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-crypt/mit-krb5
+ dev-db/sqlite
+ dev-libs/glib
+ dev-libs/icu
+ dev-libs/libxslt
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base
+ media-libs/libjpeg-turbo
+ media-libs/mesa
+ media-libs/tiff
+ sci-libs/gsl
+ sci-libs/pgplot
+ sys-apps/keyutils
+ sys-apps/util-linux
+ sys-devel/gcc[fortran]
+ virtual/libffi
+ x11-libs/libdrm
+ x11-libs/libSM
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+
+S="${WORKDIR}/${MY_P}"
+QA_PREBUILT="/opt/casapy/* /opt/casapy/sbin/* /opt/casapy/lib64/*"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /opt/
+ cp -R "${S}" "${D}/opt/casapy" || die "Could not copy casapy into ${D}/opt"
+
+ dodir /opt/bin
+ cd "${D}/opt/casapy/bin"
+ for binary in `ls`
+ do
+ dosym ../casapy/$binary /opt/bin/$binary
+ done
+}
+
+pkg_postinst() {
+ einfo "CASA will use media-gfx/graphviz if this package is installed."
+ ewarn "Upstream warns that SElinux must be disabled, set to permissive, or configured to allow execheap."
+}