aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cluster/cluster-1.36.ebuild')
-rw-r--r--sci-biology/cluster/cluster-1.36.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-biology/cluster/cluster-1.36.ebuild b/sci-biology/cluster/cluster-1.36.ebuild
new file mode 100644
index 000000000..5af64c16b
--- /dev/null
+++ b/sci-biology/cluster/cluster-1.36.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+inherit autotools
+SRC_URI="${P}.tar.gz"
+
+DESCRIPTION="Clustering software for microarray analysis"
+HOMEPAGE="http://bonsai.ims.u-tokyo.ac.jp/~mdehoon/software/cluster/software.htm#ctv"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( virtual/motif )"
+RDEPEND="X? ( x11-misc/xdg-utils app-text/xpdf )"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Please obtain ${P}.tar.gz from ${HOMEPAGE} and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -i \
+ -e 's:^docdir = $(prefix)/cluster/doc:docdir = @docdir@:' \
+ -e 's:^htmldir = $(prefix)/cluster/html:htmldir = @htmldir@:' \
+ -e 's:^imagedir = $(prefix)/cluster/html/images:imagedir = @htmldir@/images:' \
+ -e 's:^fileformatdir = $(prefix)/cluster:fileformatdir = @docdir@:' \
+ X11/Makefile.in || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-helpmenu-fix.patch" || die "failed to patch helpmenu"
+
+}
+
+src_compile() {
+
+ econf $(use_with X x) \
+ --docdir="/usr/share/doc/${P}" \
+ --htmldir="/usr/share/doc/${P}/html" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dodoc README COPYING AUTHORS ChangeLog NEWS TODO || die "failed to install docs"
+ insinto /usr/share/doc/${P}/examples
+ doins example/example.c example/README || die "failed to install docs"
+ insinto /usr/share/doc/${P}
+ doins doc/cluster.pdf || die "failed to install docs"
+
+}