aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/dipy/dipy-9999.ebuild')
-rw-r--r--sci-biology/dipy/dipy-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/dipy/dipy-9999.ebuild b/sci-biology/dipy/dipy-9999.ebuild
new file mode 100644
index 000000000..beb75e456
--- /dev/null
+++ b/sci-biology/dipy/dipy-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="computational neuroanatomy project focusing on diffusion MRI"
+HOMEPAGE="http://nipy.org/dipy"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/nipy/dipy"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ nosetests || die
+}
+