aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/gbrowse/gbrowse-2.45.ebuild')
-rw-r--r--sci-biology/gbrowse/gbrowse-2.45.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-biology/gbrowse/gbrowse-2.45.ebuild b/sci-biology/gbrowse/gbrowse-2.45.ebuild
index 4b3f3b38a..f1b510fcf 100644
--- a/sci-biology/gbrowse/gbrowse-2.45.ebuild
+++ b/sci-biology/gbrowse/gbrowse-2.45.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
-inherit perl-module webapp
+EAPI=4
+
+inherit eutils perl-module webapp
MY_P="GBrowse-${PV}"
@@ -91,12 +92,13 @@ RDEPEND="${DEPEND}
src_prepare() {
sed -i 's/return unless -t STDIN/return/' install_util/GBrowseInstall.pm || die "Failed to kill the interactive behavior of install_util/GBrowseInstall.pm"
sed -i 's/process_/bp_process_/g' INSTALL || die "Failed to prepend bp_ prefix to INSTALL file"
- epatch "${FILESDIR}"/GBrowseInstall.pm-"${PV}".patch || die "Failed to apply GBrowseInstall.pm-"${PV}".patch"
- epatch "${FILESDIR}"/destdir.patch || die "Failed to apply destdir.patch"
- epatch "${FILESDIR}"/fix-PNG-export.patch || die "Failed to apply fix-PNG-export.patch"
- epatch "${FILESDIR}"/symlink.patch || die "Failed to apply symlink.patch"
- epatch "${FILESDIR}"/gbrowse_metadb_config.pl.patch || die "Failed to apply gbrowse_metadb_config.pl.patch"
- epatch "${FILESDIR}"/disable-gbrowse_metadb_config.pl.patch || die "Failed to apply disable-gbrowse_metadb_config.pl.patch"
+ epatch \
+ "${FILESDIR}"/GBrowseInstall.pm-"${PV}".patch \
+ "${FILESDIR}"/destdir.patch \
+ "${FILESDIR}"/fix-PNG-export.patch \
+ "${FILESDIR}"/symlink.patch \
+ "${FILESDIR}"/gbrowse_metadb_config.pl.patch \
+ "${FILESDIR}"/disable-gbrowse_metadb_config.pl.patch
for f in conf/synteny/wild_rice_synteny.conf conf/synteny/rice_synteny.conf conf/GBrowse.conf \
htdocs/tutorial/tutorial.html htdocs/index.html lib/Bio/Graphics/Browser2/Action.pm \
Changes; do