aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/kat/kat-9999.ebuild')
-rw-r--r--sci-biology/kat/kat-9999.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/sci-biology/kat/kat-9999.ebuild b/sci-biology/kat/kat-9999.ebuild
deleted file mode 100644
index acbdac423..000000000
--- a/sci-biology/kat/kat-9999.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-# https://github.com/Ensembl/Bio-DB-HTS/issues/30
-
-inherit autotools distutils-r1 git-r3
-
-DESCRIPTION="K-mer Analysis Toolkit (histogram, filter, compare sets, plot)"
-HOMEPAGE="https://github.com/TGAC/KAT"
-EGIT_REPO_URI="https://github.com/TGAC/KAT.git"
-EGIT_CHECKOUT_DIR="${WORKDIR}"/KAT-Release-"${PV}"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS=""
-IUSE="cpu_flags_x86_sse static-libs test"
-
-CDEPEND="
- >=dev-libs/boost-1.52[${PYTHON_USEDEP}]
- sys-libs/zlib
- dev-python/tabulate[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
- test? ( sys-process/time )"
-RDEPEND="${CDEPEND}"
-# contains bundled and *modified* version of jellyfish-2.2.0
-# (libkat_jellyfish.{a,so} and "kat_" prefixes are added to all binaries)
-# https://github.com/TGAC/KAT/issues/93#issuecomment-383377666
-# contains embedded sci-biology/seqan headers
-
-PATCHES=(
- "${FILESDIR}"/kat-2.4.2-ignore-bundled-deps.patch
- "${FILESDIR}"/kat-2.4.2-no_static_build.patch
- )
-
-S="${WORKDIR}"/KAT-Release-"${PV}"
-
-distutils_enable_sphinx "${S}/doc/source" --no-autodoc
-distutils_enable_tests pytest
-
-src_prepare(){
- default
- rm -rf deps/boost || die "Failed to zap bundled boost"
- eautoreconf
-}
-
-src_configure(){
- python_setup
- local myconf=()
- myconf+=(
- --disable-gnuplot
- --disable-pykat-install
- $(use_enable static-libs static)
- ) # python3 does better image rendering, no need for gnuplot
- # pass down to jellyfish-2.2.0/configure
- use cpu_flags_x86_sse && myconf+=( $(use_with cpu_flags_x86_sse sse) )
- econf ${myconf[@]}
-}
-
-src_compile(){
- default
- pushd scripts >/dev/null || die
- distutils-r1_src_compile
- popd > /dev/null || die
-}
-
-src_install(){
- default
- pushd scripts >/dev/null || die
- distutils-r1_src_install
- popd > /dev/null || die
-}
-
-src_test(){
- default
- python_foreach_impl python_test
-}