aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/nilearn/nilearn-0.8.1.ebuild')
-rw-r--r--sci-biology/nilearn/nilearn-0.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/nilearn/nilearn-0.8.1.ebuild b/sci-biology/nilearn/nilearn-0.8.1.ebuild
new file mode 100644
index 000000000..3064c0ba5
--- /dev/null
+++ b/sci-biology/nilearn/nilearn-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast and easy statistical learning on NeuroImaging data"
+HOMEPAGE="http://nilearn.github.io/"
+SRC_URI="https://github.com/nilearn/nilearn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Tests attempt to download external data.
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=sci-libs/scikit-learn-0.21[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. epytest
+}