aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/perga/perga-9999.ebuild')
-rw-r--r--sci-biology/perga/perga-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/perga/perga-9999.ebuild b/sci-biology/perga/perga-9999.ebuild
new file mode 100644
index 000000000..4f79d7210
--- /dev/null
+++ b/sci-biology/perga/perga-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3 eutils toolchain-funcs
+
+DESCRIPTION="Paired End Reads Guided Assembler"
+HOMEPAGE="https://github.com/hitbio/PERGA
+ http://www.ncbi.nlm.nih.gov/pmc/articles/PMC4252104"
+EGIT_REPO_URI="https://github.com/hitbio/PERGA.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -e "s/gcc -g /$(tc-getCC) ${CFLAGS} ${LDFLAGS} /" -i src/Makefile || die
+ sed -e 's/-Wl,-O1//' -i src/Makefile || die
+}
+
+# does not compile with gcc-5.3.0 but 4.9.3 works
+src_compile(){
+ cd src || die
+ emake
+}
+
+src_install(){
+ dobin src/perga
+ dodoc README
+}