aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/psychopy/psychopy-1.75.01.ebuild')
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index f4469cee4..db7ffd360 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -28,13 +28,15 @@ RDEPEND="
dev-python/wxpython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- app-admin/eselect
dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]"
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
-DEPEND="app-arch/unzip
+DEPEND="app-admin/eselect
+ app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? ( ${RDEPEND} )
+ "
RESTRICT="test" # interactive, opens lots of windows
@@ -43,7 +45,7 @@ S="${WORKDIR}/${MY_P}"
python_install_all() {
distutils-r1_python_install_all
doicon psychopy/monitors/psychopy.ico
- make_desktop_entry psychopyapp.py PsychoPy psychopy "Science;Biology"
+ make_desktop_entry psychopyapp.py PsychoPy psychopy
}
pkg_postinst() {