aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/samtools/files/samtools-1.3.1-buildsystem.patch')
-rw-r--r--sci-biology/samtools/files/samtools-1.3.1-buildsystem.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/sci-biology/samtools/files/samtools-1.3.1-buildsystem.patch b/sci-biology/samtools/files/samtools-1.3.1-buildsystem.patch
new file mode 100644
index 000000000..bd0f20c7c
--- /dev/null
+++ b/sci-biology/samtools/files/samtools-1.3.1-buildsystem.patch
@@ -0,0 +1,75 @@
+--- samtools-1.3.1/Makefile.ori 2016-04-22 11:51:16.000000000 +0200
++++ samtools-1.3.1/Makefile 2017-02-16 23:41:19.819951687 +0100
+@@ -21,9 +21,9 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
++CC ?= gcc
+ CPPFLAGS =
+-CFLAGS = -g -Wall -O2
++CFLAGS ?= -g -Wall -O2
+ LDFLAGS =
+ LIBS =
+
+@@ -197,8 +203,8 @@
+ # For tests that might use it, set $REF_PATH explicitly to use only reference
+ # areas within the test suite (or set it to ':' to use no reference areas).
+ # (regression.sh sets $REF_PATH to a subdirectory itself.)
+-check test: samtools $(BGZIP) $(BUILT_TEST_PROGRAMS)
+- REF_PATH=: test/test.pl --exec bgzip=$(BGZIP)
++check test: samtools $(BUILT_TEST_PROGRAMS)
++ REF_PATH=: test/test.pl --exec bgzip=bgzip
+ test/merge/test_bam_translate test/merge/test_bam_translate.tmp
+ test/merge/test_rtrans_build
+ test/merge/test_trans_tbl_init
+@@ -210,28 +216,28 @@
+ test/split/test_parse_args
+
+
+-test/merge/test_bam_translate: test/merge/test_bam_translate.o test/test.o sam_opts.o $(HTSLIB)
++test/merge/test_bam_translate: test/merge/test_bam_translate.o test/test.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/merge/test_bam_translate.o test/test.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/merge/test_rtrans_build: test/merge/test_rtrans_build.o sam_opts.o $(HTSLIB)
++test/merge/test_rtrans_build: test/merge/test_rtrans_build.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/merge/test_rtrans_build.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/merge/test_trans_tbl_init: test/merge/test_trans_tbl_init.o sam_opts.o $(HTSLIB)
++test/merge/test_trans_tbl_init: test/merge/test_trans_tbl_init.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/merge/test_trans_tbl_init.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/split/test_count_rg: test/split/test_count_rg.o test/test.o sam_opts.o $(HTSLIB)
++test/split/test_count_rg: test/split/test_count_rg.o test/test.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/split/test_count_rg.o test/test.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/split/test_expand_format_string: test/split/test_expand_format_string.o test/test.o sam_opts.o $(HTSLIB)
++test/split/test_expand_format_string: test/split/test_expand_format_string.o test/test.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/split/test_expand_format_string.o test/test.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/split/test_filter_header_rg: test/split/test_filter_header_rg.o test/test.o sam_opts.o $(HTSLIB)
++test/split/test_filter_header_rg: test/split/test_filter_header_rg.o test/test.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/split/test_filter_header_rg.o test/test.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/split/test_parse_args: test/split/test_parse_args.o test/test.o sam_opts.o $(HTSLIB)
++test/split/test_parse_args: test/split/test_parse_args.o test/test.o sam_opts.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/split/test_parse_args.o test/test.o sam_opts.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-test/vcf-miniview: test/vcf-miniview.o $(HTSLIB)
++test/vcf-miniview: test/vcf-miniview.o
+ $(CC) -pthread $(ALL_LDFLAGS) -o $@ test/vcf-miniview.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+ test_test_h = test/test.h $(htslib_sam_h)
+@@ -258,10 +264,10 @@
+ misc/maq2sam-long: misc/maq2sam-long.o
+ $(CC) $(LDFLAGS) -o $@ misc/maq2sam-long.o $(ALL_LIBS)
+
+-misc/md5fa: misc/md5fa.o $(HTSLIB)
++misc/md5fa: misc/md5fa.o
+ $(CC) $(ALL_LDFLAGS) -o $@ misc/md5fa.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+-misc/md5sum-lite: misc/md5sum-lite.o $(HTSLIB)
++misc/md5sum-lite: misc/md5sum-lite.o
+ $(CC) $(ALL_LDFLAGS) -o $@ misc/md5sum-lite.o $(HTSLIB_LIB) $(ALL_LIBS)
+
+ misc/wgsim: misc/wgsim.o