aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/edena/ChangeLog9
-rw-r--r--sci-biology/edena/Manifest1
-rw-r--r--sci-biology/edena/edena-3.131028.ebuild35
-rw-r--r--sci-biology/edena/metadata.xml9
-rw-r--r--sci-biology/epga/ChangeLog10
-rw-r--r--sci-biology/epga/epga-9999.ebuild36
-rw-r--r--sci-biology/epga/metadata.xml9
-rw-r--r--sci-biology/mosaik/ChangeLog11
-rw-r--r--sci-biology/mosaik/Manifest2
-rw-r--r--sci-biology/mosaik/mosaik-2.2.3.ebuild (renamed from sci-biology/mosaik/mosaik-2.1.33.ebuild)10
-rw-r--r--sci-biology/quast/ChangeLog11
-rw-r--r--sci-biology/quast/Manifest2
-rw-r--r--sci-biology/quast/quast-2.3.ebuild (renamed from sci-biology/quast/quast-2.2.ebuild)4
-rw-r--r--sci-biology/sabre/ChangeLog9
-rw-r--r--sci-biology/sabre/metadata.xml9
-rw-r--r--sci-biology/sabre/sabre-9999.ebuild39
-rw-r--r--sci-biology/sickle/ChangeLog6
-rw-r--r--sci-biology/sickle/sickle-9999.ebuild4
18 files changed, 203 insertions, 13 deletions
diff --git a/sci-biology/edena/ChangeLog b/sci-biology/edena/ChangeLog
new file mode 100644
index 000000000..a3f0909cc
--- /dev/null
+++ b/sci-biology/edena/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-biology/edena
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*edena-3.131028 (15 Jan 2015)
+
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +edena-3.131028.ebuild, +metadata.xml:
+ sci-biology/edena: new package
diff --git a/sci-biology/edena/Manifest b/sci-biology/edena/Manifest
new file mode 100644
index 000000000..cbe128f7c
--- /dev/null
+++ b/sci-biology/edena/Manifest
@@ -0,0 +1 @@
+DIST EdenaV3.131028.tar.gz 497784 SHA256 4037fce486c9725107b1690fbc67731713eef54e3fa53081865904c783533230 SHA512 853a5eb0afe507ba7b967075795593df147ad87c7d45be30eac6b24054ec365d7db39c9cd20bb414478a629c98c82bf0621c007c22a447949ee3f749907cae58 WHIRLPOOL 409bdb1e2f4f344198bff0af50e78afd75fffa10b4c252316a61f0c55e49bb4bdb514ed2414343056d31783e27d8ae800f7e33495cbc8f6c61ec57c5c5d974d8
diff --git a/sci-biology/edena/edena-3.131028.ebuild b/sci-biology/edena/edena-3.131028.ebuild
new file mode 100644
index 000000000..0c4fe10b3
--- /dev/null
+++ b/sci-biology/edena/edena-3.131028.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="De novo short read assembler"
+HOMEPAGE="http://www.genomic.ch/edena.php"
+SRC_URI="http://www.genomic.ch/edena/EdenaV"${PV}".tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/EdenaV"${PV}"
+
+src_prepare(){
+ sed -e "s@^CCC.*@CCC = $(tc-getCXX)@" -e "s@^CFLAGS.*@CFLAGS = ${CFLAGS} -pthread@" -i src/Makefile || die
+}
+
+src_compile(){
+ cd src
+ emake
+}
+
+src_install(){
+ dobin src/edena
+ dodoc referenceManual.pdf
+}
diff --git a/sci-biology/edena/metadata.xml b/sci-biology/edena/metadata.xml
new file mode 100644
index 000000000..2bc893037
--- /dev/null
+++ b/sci-biology/edena/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/epga/ChangeLog b/sci-biology/epga/ChangeLog
new file mode 100644
index 000000000..5d20948a1
--- /dev/null
+++ b/sci-biology/epga/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/epga
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*epga-9999 (15 Jan 2015)
+
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +epga-9999.ebuild,
+ +metadata.xml:
+ new package; no LICENSE file
+
diff --git a/sci-biology/epga/epga-9999.ebuild b/sci-biology/epga/epga-9999.ebuild
new file mode 100644
index 000000000..63a50e614
--- /dev/null
+++ b/sci-biology/epga/epga-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+[ "$PV" == "9999" ] && inherit git-2
+
+inherit toolchain-funcs
+
+DESCRIPTION="De novo assembler using distribution of reads and insert size"
+HOMEPAGE="https://github.com/bioinfomaticsCSU/EPGA"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/bioinfomaticsCSU/EPGA.git"
+ KEYWORDS=""
+else
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ $(tc-getCXX) ${CFLAGS} main.cpp -o epga -lpthread
+}
+
+src_install(){
+ dobin epga
+ dodoc README.md
+}
diff --git a/sci-biology/epga/metadata.xml b/sci-biology/epga/metadata.xml
new file mode 100644
index 000000000..2bc893037
--- /dev/null
+++ b/sci-biology/epga/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/mosaik/ChangeLog b/sci-biology/mosaik/ChangeLog
index 87f4c4bbb..51160219f 100644
--- a/sci-biology/mosaik/ChangeLog
+++ b/sci-biology/mosaik/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for sci-biology/mosaik
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mosaik-2.2.3 (15 Jan 2015)
+
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +mosaik-2.2.3.ebuild, -mosaik-2.1.33.ebuild:
+ version bump, masking a crappy package until at least the Makefile's
+ propagate an error code back to upstream caller, https://code.google.com/p
+ /mosaik-aligner/issues/detail?id=135
+
07 Jan 2014; Justin Lecher <jlec@gentoo.org> mosaik-2.1.33.ebuild,
mosaik-9999.ebuild, metadata.xml:
Readd ebuild
@@ -33,4 +41,3 @@
Fastq.cpp:224, Fastq.cpp:226, Fasta.cpp:258, Fasta.cpp:260, Fasta.cpp:266,
Fasta.cpp:268, but the package itself installs and executes at least
mosaik-1.1.0021.ebuild
-
diff --git a/sci-biology/mosaik/Manifest b/sci-biology/mosaik/Manifest
index e7f7074d3..c378492e7 100644
--- a/sci-biology/mosaik/Manifest
+++ b/sci-biology/mosaik/Manifest
@@ -1,2 +1,2 @@
-DIST MOSAIK-2.1.33-source.tar 3911680 SHA256 210764cddbd8a3866976f065b912eb30fcd94d681901be93b42724708b86e2aa SHA512 9eeda8698bc929f95ff16b4e611174f631a5affb8712d582eda7e02a45f27ea8a50ffc56c6595f837af342f266a5bfe44ca1eb006d301caef671e01ed794ba20 WHIRLPOOL 89b65f5ff47dbce615f37e4ae2d3d207cde1482f3e9d4cb280cca55c399784eeb272d3af490327b3c1ac348f7d6bdc1305df67a726acea7b9e2502df02848136
+DIST MOSAIK-2.2.3-source.tar 3819520 SHA256 b2b291603949f179d5f0686045aaf48ab34ea47001bc1e0c573adf517e8b3b28 SHA512 d60a0559dced935f736ca105569593165474134985b1d32405c8f4537dc5da7a05d89ce3a10e4536e2b4f62f622055c327abddb3783c9331465061c5f866129f WHIRLPOOL a66221037900f64c15dc6f444ff19be5bb3496625d426515b5fb33c8b181d35ab69d6f383ce92912d4354c8b9acc1d23d68c544e38db056c0ef1314875dfadcf
DIST Mosaik-1.0-Documentation.pdf 10589 SHA256 470e2a534668a2a8744df7b00b9b8af5a6966d2df70f0ab1a4b271bdddadae9c SHA512 b2febce1e85eea89e5ff5d9f1aae351c59574314f361b66503ec473da7641adc083e52ee739c04abfe5b074fd57271f2ca20bea215982ee3ecfce073bbfd7b38 WHIRLPOOL 764a984408590417345daf624cda3dfb5df4255f18efc8f8cfbfc61885ed14be9863eef886dacfe90562469cd6af50220c0a776653a429b888eedac86270dc06
diff --git a/sci-biology/mosaik/mosaik-2.1.33.ebuild b/sci-biology/mosaik/mosaik-2.2.3.ebuild
index bc26a056b..6bd994ba8 100644
--- a/sci-biology/mosaik/mosaik-2.1.33.ebuild
+++ b/sci-biology/mosaik/mosaik-2.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -13,10 +13,16 @@ SRC_URI="
LICENSE="GPL-2 || ( MIT )"
SLOT="0"
IUSE=""
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
+
+# https://code.google.com/p/mosaik-aligner/issues/detail?id=135
S="${WORKDIR}"/MOSAIK-${PV}-source
+src_prepare(){
+ sed -e "s@export LDFLAGS = -Wl@#export LDFLAGS = -Wl@" -i Makefile
+}
+
src_install() {
dobin "${WORKDIR}"/bin/*
diff --git a/sci-biology/quast/ChangeLog b/sci-biology/quast/ChangeLog
index ccf3a0e68..e29320d4a 100644
--- a/sci-biology/quast/ChangeLog
+++ b/sci-biology/quast/ChangeLog
@@ -1,7 +1,16 @@
# ChangeLog for sci-biology/quast
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> quast-2.3.ebuild:
+ added a note about additional bundled package licenses
+
+*quast-2.3 (15 Jan 2015)
+
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +quast-2.3.ebuild,
+ -quast-2.2.ebuild:
+ version bump
+
13 Nov 2014; Justin Lecher <jlec@gentoo.org> quast-2.2.ebuild, metadata.xml:
Bump to new python eclasses
diff --git a/sci-biology/quast/Manifest b/sci-biology/quast/Manifest
index 9ddb43cb2..f89b3dc4e 100644
--- a/sci-biology/quast/Manifest
+++ b/sci-biology/quast/Manifest
@@ -1 +1 @@
-DIST quast-2.2.tar.gz 19814517 SHA256 c66cb9b063d82962bceb11762794fb2e5a57846c8a3aa93ca5f83951cf669d85 SHA512 e979b63f53c3909f804d733ae2cbfd0963fca3dc9194b2a04c8d7be53d253d087853520198a8261a5eba186369486f6e2f4d469814a2d8632072bd73d0e5b8bb WHIRLPOOL 76078a45e24a961acd6fafadf26d08daa79d0b65f224d1bfb87fd404532161c4b667a2873fcf1023e7156bc1c5273de48adb7bfcc5eee68bd3218d03db3aaaa2
+DIST quast-2.3.tar.gz 17631110 SHA256 efad099097e4d148b02e98892c5e93a2407c4debecb12860629142192be62b0d SHA512 eddece31d2ba51548f3e395f77a382d019ef282fb97c5ecfa18cf124c6a619bee760f238b046517a67b7ccbc5354ff36666d0f01cc75b098e9baee2dd3652f40 WHIRLPOOL 82520b21ba791918f05d75e7cc098e54628af1f73bb3735efcd86c2eb669029a28ef40756b7c4aa23e0cd6a547032428cfcb718bbcd9aa970e43e1aa89d4667c
diff --git a/sci-biology/quast/quast-2.2.ebuild b/sci-biology/quast/quast-2.3.ebuild
index 383914717..701f274f4 100644
--- a/sci-biology/quast/quast-2.2.ebuild
+++ b/sci-biology/quast/quast-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -12,7 +12,7 @@ DESCRIPTION="Compare quality of multiple genome assemblies to each other"
HOMEPAGE="http://bioinf.spbau.ru/QUAST"
SRC_URI="http://sourceforge.net/projects/quast/files/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2" # and some other for the bundled copies, see http://quast.bioinf.spbau.ru/LICENSE
SLOT="0"
KEYWORDS=""
IUSE=""
diff --git a/sci-biology/sabre/ChangeLog b/sci-biology/sabre/ChangeLog
new file mode 100644
index 000000000..f7f747fa1
--- /dev/null
+++ b/sci-biology/sabre/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-biology/sabre
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*sabre-9999 (15 Jan 2015)
+
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +metadata.xml,
+ +sabre-9999.ebuild:
+ sci-biology/sabre: new package
diff --git a/sci-biology/sabre/metadata.xml b/sci-biology/sabre/metadata.xml
new file mode 100644
index 000000000..2bc893037
--- /dev/null
+++ b/sci-biology/sabre/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/sabre/sabre-9999.ebuild b/sci-biology/sabre/sabre-9999.ebuild
new file mode 100644
index 000000000..2aee70121
--- /dev/null
+++ b/sci-biology/sabre/sabre-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+[ "$PV" == "9999" ] && inherit git-2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Barcode demultiplexing and trimming tool for Illumina FastQ files"
+HOMEPAGE="https://github.com/najoshi/sabre"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/najoshi/sabre.git"
+ KEYWORDS=""
+else
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+
+LICENSE="MIT" # almost verbatim
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${S}"/src
+
+src_prepare(){
+ sed -e "s#OPT = -O3#OPT = ${CFLAGS}#" \
+ -e "s#CC = gcc#CC = $(tc-getCC)#" -i Makefile || die
+}
+
+src_install(){
+ dobin sabre
+}
diff --git a/sci-biology/sickle/ChangeLog b/sci-biology/sickle/ChangeLog
index bdbc7e730..443ff95fa 100644
--- a/sci-biology/sickle/ChangeLog
+++ b/sci-biology/sickle/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for sci-biology/sickle
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> sickle-9999.ebuild:
+ correct package description
+
*sickle-9999 (24 Mar 2014)
24 Mar 2014; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+sickle-9999.ebuild, +metadata.xml:
simple ebuild, bundled Makefile forces compile flags, program version, but
works
-
diff --git a/sci-biology/sickle/sickle-9999.ebuild b/sci-biology/sickle/sickle-9999.ebuild
index d256d7313..022474e57 100644
--- a/sci-biology/sickle/sickle-9999.ebuild
+++ b/sci-biology/sickle/sickle-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI=5
inherit eutils git-r3
-DESCRIPTION="Windowed adaptive adaptor trimming tool for FASTQ data from Illumina/Solexa"
+DESCRIPTION="Windowed adaptive quality-based trimming tool for FASTQ data from Illumina/Solexa"
HOMEPAGE="https://github.com/najoshi/sickle"
EGIT_REPO_URI="https://github.com/najoshi/sickle"