aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/act-bin/Manifest4
-rw-r--r--sci-biology/act-bin/act-bin-13.0.0.ebuild50
-rw-r--r--sci-biology/act-bin/metadata.xml12
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-biology/act-bin/Manifest b/sci-biology/act-bin/Manifest
new file mode 100644
index 000000000..0ca1980c8
--- /dev/null
+++ b/sci-biology/act-bin/Manifest
@@ -0,0 +1,4 @@
+DIST act-bin-13.0.0.html_build.zip 2067725 SHA256 6a07ff70aef13e633884491c83832c150532eb0f199c0c382bab8dd4d23c3f4d SHA512 c119b12a68e52249f3a417c503129b8e538baae218cda07cd4d52b34eab9be7cdbfc86180c6675f26afe8bac556e18b66a94407f00a133c58a2e1c626f6d3571 WHIRLPOOL ca4b5367aabf22e56d394d18d0546d132400fb6d28a9433b9524f89ef181acc06406b7230563444b5a2df8dd08ea4ee740c9b94d928c6830d3e5736723071c41
+DIST act-bin-13.0.0.manual.pdf 946922 SHA256 460adb7a9c5cd6f6e5b0bf499ddec48fddf0c475824c363db9ae8e6e7b1f0ade SHA512 6af8bf6fb9cf762c078288a09cae053c9c08f5d44dd8d7324acaaa73b63d79e107a403c5dbef48a319408e0158d3ace146f6ed29d55cb553e668be711ae73914 WHIRLPOOL 01cbd2cc1139d732f61ea21782dc13935369746c1eee3b83babf07fc47f76425c00297af6c253fddbb9c4d3d16ff3ce9a03a7596dde1419f4128e30b128ec176
+DIST act_v13.jar 11005084 SHA256 5aa943b851a596d7ef9354c495d7fd7b86e05a942bab6f5db4a459fa7a580a19 SHA512 693e55d2c1f71e99f981114aa9715dac7386bedaf6bd753b49ea58f1a4ef30b5f603384cf7c5b43d3c95eebc71dc66eba04e51b0303a80566c0a8d186f473d4d WHIRLPOOL dbbaea5b3c239ceb342ad8b6cf41bdbf995abb58c5cbf28ee4330271ebcd7dc05a336f3154f88e7b0fc3b7aeab5e4a8229eb7628dfa04245b9883e08903ea1ec
+DIST sact_v13.jar 11533674 SHA256 c20b4bc0cafbd4d7aa577009c4ea89a78405230ab44b20aac01c715b03ecd8f6 SHA512 365c82933ebd4c20448a6872c4b3a5ddee313aa137bc83bf8b95a677fa7bcf32920be185971c00116d6e524357975ef633fe25496d124b6001eecdc698afcfaf WHIRLPOOL 22e576045369e251aa93a2da9081c841eaf11cc2f7804a354651ff9f40d4d36d3fed3662bd7596d3b5c633dab0ef688cecaae1bedd049d2dc97fd43f776eaeb0
diff --git a/sci-biology/act-bin/act-bin-13.0.0.ebuild b/sci-biology/act-bin/act-bin-13.0.0.ebuild
new file mode 100644
index 000000000..debf770c0
--- /dev/null
+++ b/sci-biology/act-bin/act-bin-13.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit java-pkg-2
+
+DESCRIPTION="DNA contig sequence comparison tool supplementing Artemis"
+HOMEPAGE="http://www.sanger.ac.uk/science/tools/artemis-comparison-tool-act"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/sact_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_manual_complete.pdf -> ${P}.manual.pdf
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_html_build.zip -> ${P}.html_build.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ !sci-biology/artemis"
+RDEPEND="${DEPEND}
+ >=virtual/jre-1.6:*"
+
+S="${WORKDIR}"
+
+src_unpack(){
+ unzip "${DISTDIR}"/${P}.html_build.zip || die
+}
+
+src_prepare(){
+ default
+ cd act_html_build || die
+ rm -f .DS_Store HTML.index HTML.manifest || die
+}
+
+src_install(){
+ java-pkg_dojar "${DISTDIR}"/*.jar
+ dodoc "${DISTDIR}"/${P}.manual.pdf
+ insinto /usr/share/doc/"${PN}"/html
+ doins act_html_build/*
+}
+
+pkg_postinst(){
+ einfo "For BAM file support please install sci-biology/BamView"
+ einfo "You may find interesting the additional web resources:"
+ einfo "http://www.webact.org/WebACT"
+ einfo "http://www.hpa-bioinfotools.org.uk/pise/double_act.html"
+}
diff --git a/sci-biology/act-bin/metadata.xml b/sci-biology/act-bin/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/act-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>