aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/freeon/freeon-2013.09.16.ebuild')
-rw-r--r--sci-chemistry/freeon/freeon-2013.09.16.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/freeon/freeon-2013.09.16.ebuild b/sci-chemistry/freeon/freeon-2013.09.16.ebuild
new file mode 100644
index 000000000..0a8fc3385
--- /dev/null
+++ b/sci-chemistry/freeon/freeon-2013.09.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+FORTRAN_STANDARD=90
+
+inherit autotools-utils fortran-2
+
+REAL_PV="${PV//./-}"
+
+DESCRIPTION="an experimental suite of programs for linear scaling quantum chemistry."
+HOMEPAGE="http://www.freeon.org"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${REAL_PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ sci-libs/hdf5
+ virtual/blas
+ virtual/lapack"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${REAL_PV}"