aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog3
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.9999.ebuild4
2 files changed, 5 insertions, 2 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 6bc9948a3..cddca226d 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -3,6 +3,9 @@
# $Header: $
18 Jan 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
+ yet another update for git
+
+ 18 Jan 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
live ebuild update
30 Dec 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
diff --git a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
index 4f26fd732..0e2a9663a 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
@@ -155,7 +155,7 @@ src_configure() {
local cuda=$(cmake-utils_use cuda GMX_GPU)
[[ ${x} = "double" ]] && use cuda && cuda="-DGMX_GPU=OFF"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
- $(cmake-utils_use threads GMX_THREAD_MPI) ${cuda}
+ $(cmake-utils_use threads GMX_THREAD_MPI) ${cuda} -DGMX_OPENMM=OFF
-DGMX_BINARY_SUFFIX="${suffix}" -DGMX_LIBS_SUFFIX="${suffix}" )
BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
if [[ ${x} = float ]] && use openmm; then
@@ -169,7 +169,7 @@ src_configure() {
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_THREAD_MPI=OFF
- -DGMX_MPI=ON ${cuda}
+ -DGMX_MPI=ON ${cuda} -DGMX_OPENMM=OFF
-DGMX_BINARY_SUFFIX="_mpi${suffix}" -DGMX_LIBS_SUFFIX="_mpi${suffix}" )
BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
done