aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mgltools-webservices/mgltools-webservices-1.5.6.ebuild')
-rw-r--r--sci-chemistry/mgltools-webservices/mgltools-webservices-1.5.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-chemistry/mgltools-webservices/mgltools-webservices-1.5.6.ebuild b/sci-chemistry/mgltools-webservices/mgltools-webservices-1.5.6.ebuild
new file mode 100644
index 000000000..39062c5de
--- /dev/null
+++ b/sci-chemistry/mgltools-webservices/mgltools-webservices-1.5.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+MY_PN="WebServices"
+MY_P="${MY_PN}-${PV/_rc3/}"
+
+PYTHON_MODNAME="${MY_PN}"
+
+DESCRIPTION="MGLTools Plugin -- WebServices"
+HOMEPAGE="http://mgltools.scripps.edu"
+SRC_URI="http://mgltools.scripps.edu/downloads/tars/releases/REL${PV}/mgltools_source_${PV}.tar.gz"
+
+LICENSE="MGLTOOLS MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/zsi"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV/_/}/MGLPACKS/${MY_P}.tar.gz
+ tar xzpf mgltools_source_${PV/_/}/MGLPACKS/${MY_P}.tar.gz
+}
+
+python_prepare_all() {
+ ecvs_clean
+ find "${S}" -name LICENSE -type f -delete || die
+
+ sed \
+ -e 's:^.*CVS:#&1:g' \
+ -e 's:^.*LICENSE:#&1:g' \
+ -i "${S}"/MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}