aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
index 18b371800..f24e08453 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
@@ -84,5 +84,11 @@ src_test() {
}
src_install() {
- python_foreach_impl cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ my_impl_src_install() {
+ cd "${BUILD_DIR}"
+
+ cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ }
+
+ python_foreach_impl my_impl_src_install
}