aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild')
-rw-r--r--sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild b/sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild
index 2f868ae95..57386c17b 100644
--- a/sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild
+++ b/sci-chemistry/rosetta-tools/rosetta-tools-3.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
MY_PN="BioTools"
MY_P="${MY_PN}-${PV}"
@@ -13,14 +15,17 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RESTRICT="fetch"
+DEPEND=""
RDEPEND="dev-lang/perl"
+RESTRICT="fetch"
+
S="${WORKDIR}/${MY_PN}"
src_install() {
+ local x
for x in $(ls *.pl); do
- newbin ${x} ${x%.pl} || die "failed to install ${x}"
+ newbin ${x} ${x%.pl}
done
}