aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog10
-rw-r--r--sci-chemistry/apbs/apbs-9999.ebuild91
-rw-r--r--sci-chemistry/apbs/files/apbs-9999-manip.patch15
-rw-r--r--sci-chemistry/apbs/files/apbs-9999-prll.patch101
-rw-r--r--sci-chemistry/apbs/metadata.xml21
5 files changed, 0 insertions, 238 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
deleted file mode 100644
index 7ce467c81..000000000
--- a/sci-chemistry/apbs/ChangeLog
+++ /dev/null
@@ -1,10 +0,0 @@
-# ChangeLog for sci-chemistry/apbs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
-*apbs-9999 (01 May 2014)
-
- 01 May 2014; Justin Lecher <jlec@gentoo.org> +apbs-9999.ebuild,
- +files/apbs-9999-manip.patch, +files/apbs-9999-prll.patch, +metadata.xml:
- Add live ebuild
-
diff --git a/sci-chemistry/apbs/apbs-9999.ebuild b/sci-chemistry/apbs/apbs-9999.ebuild
deleted file mode 100644
index dcbc0f98a..000000000
--- a/sci-chemistry/apbs/apbs-9999.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r3.ebuild,v 1.5 2013/05/02 15:16:35 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils flag-o-matic git-r3 multilib python-single-r1 toolchain-funcs
-
-DESCRIPTION="Evaluation of electrostatic properties of nanoscale biomolecular systems"
-HOMEPAGE="http://www.poissonboltzmann.org/apbs/"
-SRC_URI=""
-EGIT_REPO_URI="git://git.code.sf.net/p/apbs/code"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS=""
-IUSE="debug examples +fetk mpi +openmp +tools"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/maloc[mpi=]
- virtual/blas
- sys-libs/readline
- fetk? (
- sci-libs/fetk
- sci-libs/amd
- sci-libs/umfpack
- sci-libs/superlu )
- mpi? ( virtual/mpi )"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${P}-manip.patch
- "${FILESDIR}"/${P}-prll.patch
-)
-
-DOCS=(
- doc/{APBS-1.4-README.txt,ChangeLog,README}
-)
-
-src_prepare() {
- local _examples
-
- use examples || examples=$(ls examples/*)
-
- rm -rf \
- contrib/maloc* include/Eigen/* \
- doc/{license,release_procedure.txt,programmer,CMakeLists.txt} \
- ${examples} \
- || die
-
- append-cppflags $($(tc-getPKG_CONFIG) --cflags eigen3)
-
- sed \
- -e "s:-lblas:$($(tc-getPKG_CONFIG) --libs blas):g" \
- -e 's:-lg2c::g' \
- -i CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYS_LIBPATHS="${EPREFIX}"/usr/$(get_libdir)
- -DLIBRARY_INSTALL_PATH=$(get_libdir)
- -DFETK_PATH="${EPREFIX}"/usr/
- -DBUILD_SHARED_LIBS=ON
- -DENABLE_PYTHON=ON
- $(cmake-utils_use_build tools)
- $(cmake-utils_use_enable debug)
-# Not acitve in the code yet
-# $(cmake-utils_use_enable fast)
- $(cmake-utils_use_enable fetk)
- $(cmake-utils_use_enable mpi)
- $(cmake-utils_use_enable openmp)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd tests || die
- "${PYTHON}" apbs_tester.py -l log || die
- grep -q 'FAILED' log && die "Tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- python_optimize "${ED}"
-}
diff --git a/sci-chemistry/apbs/files/apbs-9999-manip.patch b/sci-chemistry/apbs/files/apbs-9999-manip.patch
deleted file mode 100644
index fd5c1a299..000000000
--- a/sci-chemistry/apbs/files/apbs-9999-manip.patch
+++ /dev/null
@@ -1,15 +0,0 @@
- tools/CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index 1982a3c..30ab17a 100644
---- a/tools/CMakeLists.txt
-+++ b/tools/CMakeLists.txt
-@@ -1,7 +1,6 @@
- set(EXECUTABLE_OUTPUT_PATH ${TOOLS_PATH}/bin)
-
- add_subdirectory(mesh)
--add_subdirectory(manip)
-
- if(ENABLE_PYTHON)
- add_subdirectory(manip)
diff --git a/sci-chemistry/apbs/files/apbs-9999-prll.patch b/sci-chemistry/apbs/files/apbs-9999-prll.patch
deleted file mode 100644
index 99e1845bb..000000000
--- a/sci-chemistry/apbs/files/apbs-9999-prll.patch
+++ /dev/null
@@ -1,101 +0,0 @@
- CMakeLists.txt | 16 ++++++++--------
- src/CMakeLists.txt | 1 -
- src/fem/CMakeLists.txt | 2 +-
- src/pmgc/CMakeLists.txt | 2 +-
- 4 files changed, 10 insertions(+), 11 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e3f720c..6b7db4c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -61,7 +61,7 @@ set(LIBRARY_OUTPUT_PATH ${APBS_ROOT}/lib)
- set(TOOLS_PATH ${APBS_ROOT}/tools)
- set(APBS_BINARY ${EXECUTABLE_OUTPUT_PATH}/apbs)
-
--set(LIBRARY_INSTALL_PATH lib)
-+set(LIBRARY_INSTALL_PATH ${CMAKE_INSTALL_LIBDIR})
- set(HEADER_INSTALL_PATH include/apbs)
- set(EXECUTABLE_INSTALL_PATH bin)
- set(SHARE_INSTALL_PATH share/apbs)
-@@ -93,8 +93,6 @@ set(CMAKE_INCLUDE_PATH "${CMAKE_INCLUDE_PATH}")
- list(APPEND CMAKE_INCLUDE_PATH /usr/include)
- list(APPEND CMAKE_INCLUDE_PATH /usr/local/include)
-
--set(APBS_LIBS "-L${APBS_ROOT}/lib -lapbs_geoflow")
--
- ################################################################################
- # Enable ansi pedantic compiling #
- ################################################################################
-@@ -202,9 +200,11 @@ if(ENABLE_BEM)
- else()
- set(TABI_LIBRARY_BASENAME ${CMAKE_STATIC_LIBRARY_PREFIX}${TABI}${CMAKE_STATIC_LIBRARY_SUFFIX})
- endif()
--
-+
-+ file(GLOB MODS ${LIBRARY_OUTPUT_PATH}/*.mod)
-+
- install(
-- FILES ${LIBRARY_OUTPUT_PATH}/${TABI_LIBRARY_BASENAME} ${LIBRARY_OUTPUT_PATH}/*.mod
-+ FILES ${LIBRARY_OUTPUT_PATH}/${TABI_LIBRARY_BASENAME} ${MODS}
- DESTINATION ${LIBRARY_INSTALL_PATH}
- )
- set(TABI_LIBRARY ${APBS_ROOT}/${LIBRARY_INSTALL_PATH}/${TABI_LIBRARY_BASENAME})
-@@ -219,7 +219,7 @@ if(ENABLE_BEM)
- endif()
- get_filename_component(LIBGFORTRANPATH ${LIBGFORTRANPATH} PATH)
- find_path(LIBGFORTRAN_PATH ${LIBGFORTRAN_NAME} PATH ${LIBGFORTRANPATH})
-- list(APPEND APBS_LIBS "-L${APBS_ROOT}/${LIBRARY_INSTALL_PATH} -L${LIBGFORTRAN_PATH} -lgfortran -ltabipb" )
-+ list(APPEND APBS_LIBS "-L${APBS_ROOT}/lib -L${LIBGFORTRAN_PATH} -lgfortran -ltabipb" )
- endif()
-
- find_file( # this should be find path...
-@@ -237,7 +237,7 @@ endif()
-
-
- find_library(MALOC_LIBRARY "maloc"
-- PATHS ${FETK_PATH}/lib ${CONTRIB_PATH}
-+ PATHS ${FETK_PATH}/${CMAKE_INSTALL_LIBDIR} ${CONTRIB_PATH}
- DOC "The fetk/maloc library"
- )
- if(MALOC_LIBRARY)
-@@ -295,7 +295,7 @@ if(ENABLE_FETK)
- set(FETK_ENALBED 1)
-
- list(APPEND APBS_LIBS "-lstdc++")
-- list(APPEND APBS_LIBS "-L${FETK_PATH}/lib")
-+ list(APPEND APBS_LIBS "-L${FETK_PATH}/${CMAKE_INSTALL_LIBDIR}")
- list(APPEND APBS_LIBS -lamd -lpunc -lmc -lgamer -lsuperlu -lumfpack
- -lblas -lvf2c -ltetgen -ltriangle -lg2c -lreadline )
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 44d20fa..5d5150b 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -23,7 +23,6 @@ macro(add_items TYPE)
- endmacro()
-
-
--
- macro(add_sublibrary LIBRARY)
- set(LIBRARY_NAME "apbs_${LIBRARY}")
- set(LIBRARY_DEPENDENCIES ${APBS_LIBS} ${ARGN})
-diff --git a/src/fem/CMakeLists.txt b/src/fem/CMakeLists.txt
-index 5a950c2..dc37f48 100644
---- a/src/fem/CMakeLists.txt
-+++ b/src/fem/CMakeLists.txt
-@@ -12,4 +12,4 @@ add_items(
- vpee.h
- )
-
--add_sublibrary(fem)
-+add_sublibrary(fem apbs_geoflow)
-diff --git a/src/pmgc/CMakeLists.txt b/src/pmgc/CMakeLists.txt
-index 85b0c1e..97c95f0 100644
---- a/src/pmgc/CMakeLists.txt
-+++ b/src/pmgc/CMakeLists.txt
-@@ -42,4 +42,4 @@ add_items(
- mgfasd.h
- )
-
--add_sublibrary(pmgc)
-+add_sublibrary(pmgc apbs_geoflow)
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
deleted file mode 100644
index b8e509525..000000000
--- a/sci-chemistry/apbs/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher</name>
- <description>Ebuild Crasher</description>
- </maintainer>
- <use>
- <flag name="fetk">Include support for FeTK</flag>
- <flag name="tools">Install optional tools</flag>
- </use>
- <longdescription>
-APBS is a software package for modeling biomolecular solvation through solution
-of the Poisson-Boltzmann equation (PBE), one of the most popular continuum
-models for describing electrostatic interactions between molecular solutes in
-salty, aqueous media. Continuum electrostatics plays an important role in
-several areas of biomolecular simulation
-</longdescription>
-</pkgmetadata>