aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pymol/ChangeLog4
-rw-r--r--sci-chemistry/pymol/files/pymol-9999-listing.patch17
-rw-r--r--sci-chemistry/pymol/pymol-9999.ebuild1
3 files changed, 22 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 2cce80569..0364715ae 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -3,6 +3,10 @@
# $Header: $
20 Oct 2014; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild,
+ +files/pymol-9999-listing.patch:
+ Fix broken plugin listing
+
+ 20 Oct 2014; Justin Lecher <jlec@gentoo.org> pymol-9999.ebuild,
+files/pymol-9999-options.patch:
Fix upstream buildsystem
diff --git a/sci-chemistry/pymol/files/pymol-9999-listing.patch b/sci-chemistry/pymol/files/pymol-9999-listing.patch
new file mode 100644
index 000000000..1b4039c56
--- /dev/null
+++ b/sci-chemistry/pymol/files/pymol-9999-listing.patch
@@ -0,0 +1,17 @@
+ pymol/modules/pymol/plugins/repository.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/pymol/modules/pymol/plugins/repository.py b/pymol/modules/pymol/plugins/repository.py
+index 9697f68..9820fac 100644
+--- a/pymol/modules/pymol/plugins/repository.py
++++ b/pymol/modules/pymol/plugins/repository.py
+@@ -182,7 +182,8 @@ class GithubRepository(HttpRepository):
+
+ def fetchjson(self, url):
+ handle = urlopen('https://api.github.com' + url)
+- return eval(handle.read())
++ ret = handle.read().replace("false", "False")
++ return eval(ret)
+
+ class LocalRepository(Repository):
+ def __init__(self, url):
diff --git a/sci-chemistry/pymol/pymol-9999.ebuild b/sci-chemistry/pymol/pymol-9999.ebuild
index a811e69ed..cbc6a4b0e 100644
--- a/sci-chemistry/pymol/pymol-9999.ebuild
+++ b/sci-chemistry/pymol/pymol-9999.ebuild
@@ -39,6 +39,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-options.patch
+ "${FILESDIR}"/${P}-listing.patch
)
src_unpack() {