aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gromacs/Manifest3
-rw-r--r--sci-chemistry/gromacs/gromacs-3.3.3.ebuild29
2 files changed, 18 insertions, 14 deletions
diff --git a/sci-chemistry/gromacs/Manifest b/sci-chemistry/gromacs/Manifest
index d3980b7e9..42598abfc 100644
--- a/sci-chemistry/gromacs/Manifest
+++ b/sci-chemistry/gromacs/Manifest
@@ -1,2 +1,3 @@
DIST gromacs-3.3.3.tar.gz 8013789 RMD160 c7b495423eb07682e88bd7d5c61e0aa9156a17d1 SHA1 318802e39f3ca3e847261a3b96906266e32deba2 SHA256 b95becbe410b71fe9bc19b91dfeb98b940dbb2d66613c9e1de7f6d21fb7534fa
-EBUILD gromacs-3.3.3.ebuild 6015 RMD160 1d4ba26570931c5f245b66c81fb7f86349addd8d SHA1 c99f235c4afbd8fd1b91742339981ecee32ef5d7 SHA256 cbf7f0fcd1ffca365e0c6cd407ecef8abc1884a2e3a6f120f0d6401830430f39
+EBUILD gromacs-3.3.3.ebuild 6160 RMD160 e216cdc47a6fb00f6972e9c25b460fb61d842794 SHA1 e639cb7e3aaaf5856a56ca0aa94806b282cd357c SHA256 22b49024e876ae22599fc9fdaefcf76ed305628a365b4e67c701863012a948db
+MISC new 6084 RMD160 ed3f42ce18e4c3055cca5638503506c9b4e80eb4 SHA1 9bef559ef080f54b81005d3c46a3d17a06514784 SHA256 d991de5b0ef422f3ff74564bdafeb9aaff5a8d6e96c8d2afbc88113604a5ec3e
diff --git a/sci-chemistry/gromacs/gromacs-3.3.3.ebuild b/sci-chemistry/gromacs/gromacs-3.3.3.ebuild
index da49297a2..e9f5f7d04 100644
--- a/sci-chemistry/gromacs/gromacs-3.3.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-3.3.3.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="1"
LIBTOOLIZE="true"
inherit autotools eutils flag-o-matic fortran multilib
@@ -83,11 +84,6 @@ src_compile() {
# For more info:
# http://lists.debian.org/debian-gcc/2002/debian-gcc-200201/msg00150.html
- # if we don't set C[XX]FLAGS configure will set: -O3 -finline-functions
- # -funroll-all-loops
-# append-flags "-O3 -finline-functions -funroll-all-loops"
-# use x86 && append-flags "-malign-double"
-
# We will compile single precision by default, and suffix double-precision with _d.
# Sparc is the only arch I can test on that needs to use fortran.
local myconf ;
@@ -174,34 +170,41 @@ src_compile() {
if ( use double-precision && use single-precision ); then
einfo "Building Single Precison Gromacs"
cd "${WORKDIR}"/"${P}"-single
- myconf="${myconf} --enable-float"
+ myconf="${myconf} --enable-float --disable-double --program-suffix=''"
econf ${myconf} || die "Single Precision econf failed"
emake || die "Single Precision emake failed"
einfo "Building Double Precision Gromacs"
cd "${WORKDIR}"/"${P}"-double
- myconf="${myconf} --enable-double --program-suffix=_d"
+ myconf="${myconf} --enable-double --disable-float --program-suffix=_d"
econf ${myconf} || die "Double Precision econf failed"
emake || die "Double Precision emake failed"
- else
+
+ elif use double-precision ; then
+ einfo "Building Double Precison Gromacs"
+ cd "${WORKDIR}"/"${P}"-double
+ myconf="${myconf} --enable-double --disable-float --program-suffix=''"
+ econf ${myconf} || die "Double Precision econf failed"
+ emake || die "Double Precision emake failed"
+
+ elif use single-precision ; then
einfo "Building Single Precison Gromacs"
cd "${WORKDIR}"/"${P}"-single
- myconf="${myconf} $(use_enable double-precision double) \
- $(use_enable single-precision float)"
+ myconf="${myconf} --enable-float --disable-double --program-suffix=''"
econf ${myconf} || die "configure failed"
emake || die "Single Precision emake failed"
fi
}
src_install() {
- if ( use single-precision ); then
+ if use single-precision ; then
einfo "Installing Single Precision"
cd "${WORKDIR}"/"${P}"-single
emake DESTDIR="${D}" install || die "Installing Single Precision failed"
fi
- if ( use double-precision ) ; then
- einfo "Installing Double Precision"
+ if use double-precision ; then
+ einfo "Installing Double Precision"
cd "${WORKDIR}"/"${P}"-double
emake DESTDIR="${D}" install || die "Installing Double Precision failed"
fi