aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/stage/stage-2.0.3.ebuild')
-rw-r--r--sci-electronics/stage/stage-2.0.3.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/sci-electronics/stage/stage-2.0.3.ebuild b/sci-electronics/stage/stage-2.0.3.ebuild
index 9669f1562..6666e4209 100644
--- a/sci-electronics/stage/stage-2.0.3.ebuild
+++ b/sci-electronics/stage/stage-2.0.3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
inherit autotools eutils
DESCRIPTION="2D multiple-robot simulator."
@@ -14,16 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
-RDEPEND=">=x11-libs/gtk+-2.4
+RDEPEND="
+ x11-libs/gtk+:2
>=sci-electronics/player-2.0.2
x11-apps/rgb"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-docdst-fix.patch
sed -i \
-e 's;/usr/X11R6/lib/X11/rgb.txt;/usr/share/X11/rgb.txt;' \
@@ -31,9 +31,12 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
#Disable gnome-canvas since its experimental
- econf --disable-gnomecanvas || die "econf failed"
+ econf --disable-gnomecanvas
+}
+
+src_compile() {
emake || die "emake failed"
if use doc; then