aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/mpremote/Manifest1
-rw-r--r--sci-electronics/mpremote/files/mpremote-1.22.0-requirements_txt.patch12
-rw-r--r--sci-electronics/mpremote/mpremote-1.22.0.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-electronics/mpremote/Manifest b/sci-electronics/mpremote/Manifest
index a23fad530..1e55b52d3 100644
--- a/sci-electronics/mpremote/Manifest
+++ b/sci-electronics/mpremote/Manifest
@@ -1 +1,2 @@
DIST mpremote-0.4.0.tar.gz 27266 BLAKE2B b31b6184d0f4fc5c525ea7d5d8d2722404e9ce82ce143ea9a14b8bdef28af3260514dd25ec756a0ac2507d5b206fa9d07ce67bd2228b1568d9495c9082bdace8 SHA512 580f0286d8973a93105a04c681428f798e0d72b4b75debbc43f8e49ea7a81da849987aeab795baff66c9cf40607fde27fb54b7b32ab311ae5e9fb3b8f8f976fc
+DIST mpremote-1.22.0.tar.gz 24042 BLAKE2B 8bd6df4b9a46c10a93d42974a569adb42577d2783cb78b5b76ac6a6750f8219611ca49106ed91cb7f69910e3dfb28bb07a4522dbd721af0baac94d3e793c0576 SHA512 a3135e3be347370c967b7dc936f112e1ed5898288fa2dda4c485d216ebf432cb9706e539299d6769c1982ac02e456e9594ed2a7a86cbac2a1c7d08f2ff8a980b
diff --git a/sci-electronics/mpremote/files/mpremote-1.22.0-requirements_txt.patch b/sci-electronics/mpremote/files/mpremote-1.22.0-requirements_txt.patch
new file mode 100644
index 000000000..4d06c25aa
--- /dev/null
+++ b/sci-electronics/mpremote/files/mpremote-1.22.0-requirements_txt.patch
@@ -0,0 +1,12 @@
+--- a/pyproject.toml 2020-02-01 19:00:00.000000000 -0500
++++ b/pyproject.toml 2024-01-22 03:59:19.414593373 -0500
+@@ -33,9 +33,6 @@
+ [project.scripts]
+ mpremote = "mpremote.main:main"
+
+-[tool.hatch.metadata.hooks.requirements_txt]
+-files = ["requirements.txt"]
+-
+ # This will be PEP-440 normalised into either:
+ # mpremote-X.Y.Z (on vX.Y.Z release tag)
+ # mpremote-X.Y.Zrc0 (on vX.Y.Z-preview tag, i.e. first commit in the cycle)
diff --git a/sci-electronics/mpremote/mpremote-1.22.0.ebuild b/sci-electronics/mpremote/mpremote-1.22.0.ebuild
new file mode 100644
index 000000000..741478265
--- /dev/null
+++ b/sci-electronics/mpremote/mpremote-1.22.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MicroPython remote control"
+HOMEPAGE="https://github.com/micropython/micropython/tree/master/tools/mpremote"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-requirements_txt.patch"
+)
+
+# The package might not have a test suite:
+# https://github.com/orgs/micropython/discussions/11308
+#distutils_enable_tests pytest