aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.4.ebuild')
-rw-r--r--sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.4.ebuild b/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.4.ebuild
new file mode 100644
index 000000000..4ea99e888
--- /dev/null
+++ b/sci-geosciences/pydap_handlers_netcdf/pydap_handlers_netcdf-0.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN=${PN//_/.}
+MY_P=${P//_/.}
+
+DESCRIPTION="NetCDF handler for Pydap Data Access Protocol server."
+HOMEPAGE="http://pydap.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="pydap"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-python/setuptools-0.6_rc3[${PYTHON_USEDEP}]
+ >=dev-python/paver-1.0.4[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=sci-geosciences/pydap-3.0_rc8[${PYTHON_USEDEP}]
+ >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
+ >=dev-python/arrayterator-1.0.1[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ paver generate_setup || die
+ distutils-r1_python_prepare_all
+}