aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/armadillo/files/armadillo-3.810.2-hdf5.patch')
-rw-r--r--sci-libs/armadillo/files/armadillo-3.810.2-hdf5.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/armadillo/files/armadillo-3.810.2-hdf5.patch b/sci-libs/armadillo/files/armadillo-3.810.2-hdf5.patch
new file mode 100644
index 000000000..1d2e2ffcd
--- /dev/null
+++ b/sci-libs/armadillo/files/armadillo-3.810.2-hdf5.patch
@@ -0,0 +1,19 @@
+--- CMakeLists.txt.orig 2013-02-28 14:51:42.032554805 -0800
++++ CMakeLists.txt 2013-02-28 14:53:05.730978799 -0800
+@@ -191,11 +191,11 @@
+ # find_package(HDF5)
+ # message(STATUS "HDF5_FOUND = ${HDF5_FOUND}")
+ #
+-# if(HDF5_FOUND)
+-# set(ARMA_USE_HDF5 true)
+-# set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${HDF5_INCLUDE_DIRS})
+-# set(ARMA_LIBS ${ARMA_LIBS} ${HDF5_LIBRARIES})
+-# endif()
++if(HDF5_FOUND)
++ set(ARMA_USE_HDF5 true)
++ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${HDF5_INCLUDE_DIRS})
++ set(ARMA_LIBS ${ARMA_LIBS} ${HDF5_LIBRARIES})
++endif()
+
+ message(STATUS "*** ")
+ message(STATUS "*** The Armadillo run-time library component will be an alias for the following libraries:")