aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cgal-python/cgal-python-0.9.1.ebuild')
-rw-r--r--sci-libs/cgal-python/cgal-python-0.9.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sci-libs/cgal-python/cgal-python-0.9.1.ebuild b/sci-libs/cgal-python/cgal-python-0.9.1.ebuild
deleted file mode 100644
index 64ee76434..000000000
--- a/sci-libs/cgal-python/cgal-python-0.9.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit python toolchain-funcs
-
-DESCRIPTION="Provide Python bindings for the CGAL library"
-HOMEPAGE="http://cgal-python.gforge.inria.fr/"
-SRC_URI="http://gforge.inria.fr/frs/download.php/945/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="examples"
-
-DEPEND="sci-libs/cgal"
-RDEPEND="sci-libs/cgal"
-
-src_unpack(){
- python_version
- unpack "${A}"
- cd "${S}"
- # include python header needed by boost
- for i in $(find ./bindings/ -name Makefile); do
- sed "s:-I../..:-I/usr/include/python${PYVER} -I../..:g" -i $i
- sed "s:@g++:$(tc-getCXX) -fno-strict-aliasing:g" -i $i
- done
-}
-
-src_compile(){
- CGAL_MAKEFILE=/usr/share/CGAL/makefile emake
-}
-
-src_install(){
- CGAL_MAKEFILE=/usr/share/CGAL/makefile emake package
- pylibdir="$(${python} -c 'from distutils.sysconfig import get_python_lib;print get_python_lib()')"
- dodir "${pylibdir}"
- cp -r cgal_package/CGAL "${D}/${pylibdir}"
- if use example; then
- dodir /usr/share/doc/${P}
- cp -r ./test "${D}/usr/share/doc/${P}"
- fi
-}