aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/clfft/clfft-2.12.0.ebuild')
-rw-r--r--sci-libs/clfft/clfft-2.12.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-libs/clfft/clfft-2.12.0.ebuild b/sci-libs/clfft/clfft-2.12.0.ebuild
new file mode 100644
index 000000000..1776ddd5f
--- /dev/null
+++ b/sci-libs/clfft/clfft-2.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_PN="clFFT"
+
+DESCRIPTION="Library containing FFT functions written in OpenCL"
+HOMEPAGE="https://github.com/clMathLibraries/clFFT"
+SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="callback_client +client examples test"
+
+RDEPEND="
+ >=sys-devel/gcc-4.6:*
+ virtual/opencl
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+# test? (
+# dev-cpp/gtest
+# sci-libs/fftw:3.0
+# )"
+
+# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
+# Therefore src_test() won't execute any test.
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
+ die "Compilation with gcc older than 4.6 is not supported."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build callback_client CALLBACK_CLIENT)
+ $(cmake-utils_use_build client CLIENT)
+ $(cmake-utils_use_build examples EXAMPLES)
+ $(cmake-utils_use_build test TEST)
+ -DBoost_USE_STATIC_LIBS=OFF
+ )
+ cmake-utils_src_configure
+}