aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/framewave')
-rw-r--r--sci-libs/framewave/Manifest3
-rw-r--r--sci-libs/framewave/framewave-1.3.1.ebuild44
-rw-r--r--sci-libs/framewave/metadata.xml10
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/framewave/Manifest b/sci-libs/framewave/Manifest
new file mode 100644
index 000000000..e63e7afa3
--- /dev/null
+++ b/sci-libs/framewave/Manifest
@@ -0,0 +1,3 @@
+DIST FRAMEWAVE_1.3.1_SRC.tar.gz 5405064 RMD160 a01af24a31b44e51f69e9dd3bc20b3e272cb4c4b SHA1 0e292195f9f66992365e0f6e8adf4c41403dd983 SHA256 92f2f1df3be12526089db7fe35ca8ed97a1cb4feb198162f30620b72e5f44425
+EBUILD framewave-1.3.1.ebuild 972 RMD160 a69aabf281c9e36f9dbdd5cbbb3f90eba4e11f29 SHA1 beb8e1bab2d71fce28e59ee180f0e54c574c167d SHA256 f8ac0f71970cc7676e4e2a4bdd084262039b37571be6a602b0c042989285bdf3
+MISC metadata.xml 464 RMD160 0431522673e495f10fa9a5b13ac4dad7e51ffad3 SHA1 f2f05845dc20015cccd358b8225b61ff900b81a7 SHA256 ee231b2f4177344105c4e075273155c89c7e9e3127b9a22614ed88d108b8ec77
diff --git a/sci-libs/framewave/framewave-1.3.1.ebuild b/sci-libs/framewave/framewave-1.3.1.ebuild
new file mode 100644
index 000000000..efafe3674
--- /dev/null
+++ b/sci-libs/framewave/framewave-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+MY_P="FRAMEWAVE_${PV}_SRC"
+
+DESCRIPTION="A collection of popular image and signal processing routines"
+HOMEPAGE="http://framewave.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e "s#\(-install_name /usr\)/local/lib/\${BITNESS}#\1#" \
+ -i BuildTools/buildscripts/fwflags_gcc.py || die "sed failed"
+}
+
+src_compile() {
+ cd Framewave
+
+ local bits="32"
+ use amd64 && bits="64"
+
+ scons \
+ CCFLAGS="${CFLAGS}" bitness="${bits}" variant="release" \
+ libtype="shared" ${MAKEOPTS}|| die "make failed"
+}
+
+src_install() {
+ local bits="32"
+ use amd64 && bits="64"
+
+ dolib.so Framewave/build/bin/release_shared_${bits}/*.so* || die "doins failed"
+
+ insinto /usr/include
+ doins Framewave/build/include/* || die "doins failed"
+}
diff --git a/sci-libs/framewave/metadata.xml b/sci-libs/framewave/metadata.xml
new file mode 100644
index 000000000..14ebbb547
--- /dev/null
+++ b/sci-libs/framewave/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>Derived from the AMD Performance Library, Framewave is a
+ free and open-source collection of popular image and signal processing
+ routines designed to accelerate application development, debugging,
+ multi-threading and optimization on x86-class processor platforms.
+ </longdescription>
+</pkgmetadata>