aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/iml/iml-1.0.3-r2.ebuild')
-rw-r--r--sci-libs/iml/iml-1.0.3-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/iml/iml-1.0.3-r2.ebuild b/sci-libs/iml/iml-1.0.3-r2.ebuild
new file mode 100644
index 000000000..df8342c04
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.3-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="http://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="http://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RESTRICT="mirror"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_AUTORECONF=yes
+AT_M4DIR="config"
+DOCS=( AUTHORS ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${P}-use-any-cblas-implementation.patch
+ "${FILESDIR}"/${P}-fix-undefined-symbol.patch
+ "${FILESDIR}"/${P}-repl_removal.patch
+)
+
+src_configure() {
+ myeconfargs=(
+ --with-default="${EPREFIX}"/usr
+ )
+ autotools-utils_src_configure
+}