aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/io_lib/io_lib-1.14.7.ebuild')
-rw-r--r--sci-libs/io_lib/io_lib-1.14.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/io_lib/io_lib-1.14.7.ebuild b/sci-libs/io_lib/io_lib-1.14.7.ebuild
new file mode 100644
index 000000000..a0704a28c
--- /dev/null
+++ b/sci-libs/io_lib/io_lib-1.14.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="General purpose trace and experiment file reading/writing interface"
+HOMEPAGE="http://staden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+# Prototype changes in io_lib-1.9.0 create incompatibilities with BioPerl. (Only
+# versions 1.8.11 and 1.8.12 will work with the BioPerl Staden extensions.)
+#DEPEND="!sci-biology/bioperl"
+DEPEND="
+ net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ autotools-utils_src_install
+ dodoc docs/{Hash_File_Format,ZTR_format}
+}