aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapackpp/lapackpp-2.5.2.ebuild')
-rw-r--r--sci-libs/lapackpp/lapackpp-2.5.2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/sci-libs/lapackpp/lapackpp-2.5.2.ebuild b/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
deleted file mode 100644
index 7446b1229..000000000
--- a/sci-libs/lapackpp/lapackpp-2.5.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-DESCRIPTION="C++ wrapper for LAPACK"
-HOMEPAGE="http://lapackpp.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="LGPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="virtual/blas
- virtual/lapack"
-DEPEND="${DEPEND}
- dev-util/pkgconfig
- doc? ( app-doc/doxygen )"
-
-src_compile() {
- econf \
- --disable-atlas \
- --with-blas="$(pkg-config --libs blas)" \
- --with-lapack="$(pkg-config --libs lapack)" \
- || die "econf failed"
- emake || die "emake failed"
- if use doc; then
- emake srcdoc || die "emake srcdoc failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS README ChangeLog AUTHORS || die "dodoc failed"
- if use doc; then
- dohtml api-doc/html || die "dohtml failed"
- fi
-}