aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mathgl/files/mathgl-fltk.patch')
-rw-r--r--sci-libs/mathgl/files/mathgl-fltk.patch38
1 files changed, 27 insertions, 11 deletions
diff --git a/sci-libs/mathgl/files/mathgl-fltk.patch b/sci-libs/mathgl/files/mathgl-fltk.patch
index 69039df00..342a72ec2 100644
--- a/sci-libs/mathgl/files/mathgl-fltk.patch
+++ b/sci-libs/mathgl/files/mathgl-fltk.patch
@@ -1,24 +1,40 @@
-diff -U2 --recursive mathgl-1.6.2.orig/configure.ac mathgl-1.6.2/configure.ac
+diff -U2 -r mathgl-1.6.2.orig/configure.ac mathgl-1.6.2/configure.ac
--- mathgl-1.6.2.orig/configure.ac 2008-04-03 01:24:42.000000000 +0700
-+++ mathgl-1.6.2/configure.ac 2008-05-03 11:36:42.000000000 +0700
-@@ -144,8 +144,8 @@
++++ mathgl-1.6.2/configure.ac 2008-05-12 10:05:54.000000000 +0700
+@@ -144,11 +144,21 @@
*) AC_MSG_ERROR(bad value ${enableval} for --enable-fltk) ;;
esac],[fltk=false])
-AC_CHECK_HEADER(FL/Fl_Export.H,[(test x$all = xtrue || test x$fltk = xtrue) && FLTK_FLAGS=-DHAVE_FLTK AC_SUBST(FLTK_FLAGS)],
-+AC_CHECK_HEADER(@FLTK_H@FL/Fl_Export.H,[(test x$all = xtrue || test x$fltk = xtrue) && FLTK_FLAGS="-DHAVE_FLTK @FLTK_FLAGS@" AC_SUBST(FLTK_FLAGS)],
- [(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk headers" && exit])
+- [(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk headers" && exit])
-AC_CHECK_LIB([fltk], [main], [(test x$all = xtrue || test x$fltk = xtrue) && FLTK_LIBS="-lfltk -lfltk_images" AC_SUBST(FLTK_LIBS)],
-+AC_CHECK_LIB([fltk], [main], [(test x$all = xtrue || test x$fltk = xtrue) && FLTK_LIBS="@FLTK_LIBS@" AC_SUBST(FLTK_LIBS)],
- [(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk library" && exit])
- AM_CONDITIONAL(USE_FLTK, (test x$all = xtrue || test x$fltk = xtrue))
-diff -U2 --recursive mathgl-1.6.2.orig/examples/Makefile.am mathgl-1.6.2/examples/Makefile.am
+- [(test x$all = xtrue || test x$fltk = xtrue) && echo "Please install fltk library" && exit])
+-AM_CONDITIONAL(USE_FLTK, (test x$all = xtrue || test x$fltk = xtrue))
++if test x$all = xtrue || test x$fltk = xtrue
++then
++ AC_PATH_PROG([FLTKCONFIG],[fltk-config])
++ if test -n "$FLTKCONFIG"
++ then
++ FLTK_FLAGS="-DHAVE_FLTK `$FLTKCONFIG --cflags`"
++ FLTK_LIBS=`$FLTKCONFIG --use-images --ldflags`
++ AC_SUBST(FLTK_FLAGS)
++ AC_SUBST(FLTK_LIBS)],
++ else
++ echo "Please install fltk"
++ exit
++ fi
++fi
+
++AM_CONDITIONAL(USE_FLTK, (test x$all = xtrue || test x$fltk = xtrue))
+
+ AC_OUTPUT(Makefile mgl/Makefile utils/Makefile include/Makefile examples/Makefile)
+diff -U2 -r mathgl-1.6.2.orig/examples/Makefile.am mathgl-1.6.2/examples/Makefile.am
--- mathgl-1.6.2.orig/examples/Makefile.am 2008-04-03 01:24:42.000000000 +0700
-+++ mathgl-1.6.2/examples/Makefile.am 2008-05-03 11:37:28.000000000 +0700
++++ mathgl-1.6.2/examples/Makefile.am 2008-05-12 08:18:40.000000000 +0700
@@ -19,5 +19,5 @@
mgl_fltk_example_SOURCES = fltk_example.cpp
mgl_fltk_example_LDADD = $(top_builddir)/mgl/libmgl-fltk.la
-mgl_fltk_example_CFLAGS = -O2
-+mgl_fltk_example_CFLAGS = -O2 @FLTK_FLAGS@
++mgl_fltk_example_CFLAGS = -O2 $(FLTK_FLAGS)
mgl_fltk_example_CPPFLAGS = $(mgl_fltk_example_CFLAGS)
endif