aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/nfft/nfft-3.2.1.ebuild')
-rw-r--r--sci-libs/nfft/nfft-3.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/nfft/nfft-3.2.1.ebuild b/sci-libs/nfft/nfft-3.2.1.ebuild
new file mode 100644
index 000000000..41c380162
--- /dev/null
+++ b/sci-libs/nfft/nfft-3.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="library for nonequispaced discrete Fourier transform"
+HOMEPAGE="http://www-user.tu-chemnitz.de/~potts/nfft"
+SRC_URI="http://www-user.tu-chemnitz.de/~potts/nfft/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="openmp static-libs"
+
+RDEPEND="sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ use openmp && ! tc-has-openmp && \
+ die "Please switch to an openmp compatible compiler"
+}
+
+src_prepare() {
+ sed -i '25s/"\?$/"/' examples/nfsft/nfsft_benchomp.c || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-all
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}