aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/starparse/starparse-9999.ebuild')
-rw-r--r--sci-libs/starparse/starparse-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/starparse/starparse-9999.ebuild b/sci-libs/starparse/starparse-9999.ebuild
new file mode 100644
index 000000000..4b754097e
--- /dev/null
+++ b/sci-libs/starparse/starparse-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/head"
+EBZR_BOOTSTRAP="eautoreconf"
+
+inherit autotools bzr
+
+DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="guile"
+RDEPEND="guile? ( dev-scheme/guile )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable guile) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}