aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/vtk/vtk-5.6.1.ebuild')
-rw-r--r--sci-libs/vtk/vtk-5.6.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sci-libs/vtk/vtk-5.6.1.ebuild b/sci-libs/vtk/vtk-5.6.1.ebuild
index 4cd5ba2b3..ea4a50e5f 100644
--- a/sci-libs/vtk/vtk-5.6.1.ebuild
+++ b/sci-libs/vtk/vtk-5.6.1.ebuild
@@ -89,10 +89,9 @@ src_prepare() {
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"
- # Remove FindPythonLibs.cmake to use the patched one from cmake
- rm CMake/FindPythonLibs.cmake
- # Also remove it from the list of files to install
- sed -i "/FindPythonLibs.cmake/d" CMakeLists.txt
+ # Patch FindPythonLibs.cmake for python-2.7, removing it does more harm than good.
+ sed -e "s:2.6 2.5 2.4 2.3 2.2 2.1 2.0:2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0:" \
+ -i CMake/FindPythonLibs.cmake || die "failed to patch for python 2.7"
}
src_configure() {