aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/wannier90')
-rw-r--r--sci-libs/wannier90/ChangeLog7
-rw-r--r--sci-libs/wannier90/Manifest2
-rw-r--r--sci-libs/wannier90/metadata.xml8
-rw-r--r--sci-libs/wannier90/wannier90-1.2.ebuild51
4 files changed, 34 insertions, 34 deletions
diff --git a/sci-libs/wannier90/ChangeLog b/sci-libs/wannier90/ChangeLog
index 9209f04d6..dfe5c7a0c 100644
--- a/sci-libs/wannier90/ChangeLog
+++ b/sci-libs/wannier90/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-libs/wannier90
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> wannier90-1.2.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ bump to EAPI=5
+
22 Jun 2012; Alexey Shvetsov <alexxy@gentoo.org> wannier90-1.2.ebuild:
[sci-libs/wannier90] add ~amd64-linux
diff --git a/sci-libs/wannier90/Manifest b/sci-libs/wannier90/Manifest
index fa5533f4e..e9e7a8f2d 100644
--- a/sci-libs/wannier90/Manifest
+++ b/sci-libs/wannier90/Manifest
@@ -1 +1 @@
-DIST wannier90-1.2.tar.gz 5643731 RMD160 4a8035ed4faf5256ad66aa9fe23ac32a86b3abf4 SHA1 b4caaddb6e91afe673c122507e92c6b5fbc7689f SHA256 a76f88eef01c5a40aaa2c74ee393ede8a57bd9085f6b7f2ab656b50c1a30ece4 SHA512 323d078d0cdeeb361389600c39501410ca0da2879e8ba7d3262b49a76167e5385c09484eed47607d83feb68c9f16cfb6cdcebe89f7846157e0c71a8598238853 WHIRLPOOL 7e3288a85188d4661467d293d4a57973e926bf5a3b5736f83ed51e16a0fc4155ecc86e4e6dc6638b8a4d6373ca718ffd341cc11bde466d0166c1e591a9ac33c5
+DIST wannier90-1.2.tar.gz 5643731 SHA256 a76f88eef01c5a40aaa2c74ee393ede8a57bd9085f6b7f2ab656b50c1a30ece4 SHA512 323d078d0cdeeb361389600c39501410ca0da2879e8ba7d3262b49a76167e5385c09484eed47607d83feb68c9f16cfb6cdcebe89f7846157e0c71a8598238853 WHIRLPOOL 7e3288a85188d4661467d293d4a57973e926bf5a3b5736f83ed51e16a0fc4155ecc86e4e6dc6638b8a4d6373ca718ffd341cc11bde466d0166c1e591a9ac33c5
diff --git a/sci-libs/wannier90/metadata.xml b/sci-libs/wannier90/metadata.xml
index efb490d78..4bf6dbc6b 100644
--- a/sci-libs/wannier90/metadata.xml
+++ b/sci-libs/wannier90/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-libs/wannier90/wannier90-1.2.ebuild b/sci-libs/wannier90/wannier90-1.2.ebuild
index 53a77dc1d..252792245 100644
--- a/sci-libs/wannier90/wannier90-1.2.ebuild
+++ b/sci-libs/wannier90/wannier90-1.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-inherit eutils fortran-2 multilib
+inherit eutils fortran-2 multilib toolchain-funcs
DESCRIPTION="Calculates maximally localized Wannier functions (MLWFs)"
HOMEPAGE="http://www.wannier.org/"
@@ -20,13 +20,14 @@ RDEPEND="
virtual/lapack
perl? ( dev-lang/perl )"
DEPEND="${RDEPEND}
- doc? ( virtual/latex-base
- || (
- dev-texlive/texlive-latexextra
- app-text/tetex
- app-tex/ptex
- )
- )"
+ virtual/pkgconfig
+ doc? ( virtual/latex-base
+ || (
+ dev-texlive/texlive-latexextra
+ app-text/tetex
+ app-tex/ptex
+ )
+ )"
src_prepare() {
# Patch taken from sci-physics/abinit-5.7.3 bundled version
@@ -40,39 +41,33 @@ src_configure() {
F90 = $(tc-getFC)
FCOPTS = ${FCFLAGS:- ${FFLAGS:- -O2}}
LDOPTS = ${LDFLAGS}
- LIBS = $(pkg-config --libs blas lapack)
+ LIBS = $($(tc-getPKG_CONFIG) --libs blas lapack)
EOF
}
src_compile() {
- emake -j1 wannier || die "make wannier failed"
- emake -j1 lib || die "make lib failed"
- if use doc; then
- emake -j1 doc || die "make doc failed"
- fi
+ emake -j1 wannier
+ emake -j1 lib
+ use doc & emake -j1 doc
}
src_test() {
einfo "Compare the 'Standard' and 'Current' outputs of this test."
pushd tests
- emake test || die
+ emake test
cat wantest.log
}
src_install() {
- dobin wannier90.x || die "Wannier executable cannot be installed"
- if use perl; then
- ( cd utility; dobin kmesh.pl )
- fi
- dolib.a libwannier.a || die "libwannier.a cannot be installed"
+ dobin wannier90.x
+ use perl && dobin utility/kmesh.pl
+ dolib.a libwannier.a
insinto /usr/$(get_libdir)/finclude
- doins src/*.mod || die
+ doins src/*.mod
if use examples; then
- mkdir -p "${D}"/usr/share/${PN}
- cp -r examples "${D}"/usr/share/${PN}/;
- fi
- if use doc; then
- (cd doc; dodoc *.pdf )
+ insinto /usr/share/${PN}
+ doins -r examples
fi
+ use doc && dodoc doc/*.pdf
dodoc README README.install CHANGE.log
}