aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeodecomp/Manifest1
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild60
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-9999.ebuild60
3 files changed, 121 insertions, 0 deletions
diff --git a/sci-libs/libgeodecomp/Manifest b/sci-libs/libgeodecomp/Manifest
new file mode 100644
index 000000000..35639d864
--- /dev/null
+++ b/sci-libs/libgeodecomp/Manifest
@@ -0,0 +1 @@
+DIST libgeodecomp-0.1.0.tar.bz2 581136 SHA256 71442a60e7cc5c3f38e462d5d52010a948bd089759487687f217e4dec4dffae5 SHA512 56de4e6bfc92f8dda4d4931559a553a7a2c847205637394ea87f73dfb5a34776cb043beba2857bbe07c52a61ed457f22b7d76e4e23c183c8bd25868d36df4704 WHIRLPOOL df2b5c6830dbc92befd873bdced1712687046a43e814f7676271a2041a58c9e2562a86c6b4034343499f813136f38e298b33fa9a67911b726f42f323f666b03e
diff --git a/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild b/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
new file mode 100644
index 000000000..7ed246730
--- /dev/null
+++ b/sci-libs/libgeodecomp/libgeodecomp-0.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2013-2013 Andreas Schäfer
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+if [[ ${PV} == "9999" ]] ; then
+ _SCM=mercurial
+ EHG_REPO_URI="http://bitbucket.org/gentryx/libgeodecomp"
+ SRC_URI=""
+ KEYWORDS=""
+ CMAKE_USE_DIR="${S}/src"
+else
+ SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${P}/src"
+fi
+
+inherit cmake-utils vcs-snapshot ${_SCM}
+
+DESCRIPTION="LibGeoDecomp is an auto-parallelizing library to speed up your stencil code based computer simulations. It runs on virtually all current architectures, be it multi-cores, GPUs, or large scale MPI clusters. "
+HOMEPAGE="http://www.libgeodecomp.org"
+
+LICENSE="LGPL-3.0"
+SLOT="0"
+IUSE="cuda doc mpi opencl"
+
+RDEPEND=">=dev-libs/boost-1.48
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ mpi? ( || (
+ sys-cluster/openmpi[cxx]
+ sys-cluster/mpich2[cxx]
+ ) )
+ opencl? ( virtual/opencl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+
+
+# -D FEATURE_QT=false -D FEATURE_OPENCL=false -D FEATURE_CUDA=false mpi
+
+src_compile() {
+ cmake-utils_src_compile
+ if ( use doc); then
+ cmake-utils_src_compile doc
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc README
+ if ( use doc); then
+ dohtml doc/html/*
+ fi
+}
+
diff --git a/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild b/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
new file mode 100644
index 000000000..180654490
--- /dev/null
+++ b/sci-libs/libgeodecomp/libgeodecomp-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+if [[ ${PV} == "9999" ]] ; then
+ _SCM=mercurial
+ EHG_REPO_URI="http://bitbucket.org/gentryx/libgeodecomp"
+ SRC_URI=""
+ KEYWORDS=""
+ CMAKE_USE_DIR="${S}/src"
+else
+ SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/${P}/src"
+fi
+
+inherit cmake-utils vcs-snapshot ${_SCM}
+
+DESCRIPTION="LibGeoDecomp is an auto-parallelizing library to speed up your stencil code based computer simulations. It runs on virtually all current architectures, be it multi-cores, GPUs, or large scale MPI clusters. "
+HOMEPAGE="http://www.libgeodecomp.org"
+
+LICENSE="LGPL-3.0"
+SLOT="0"
+IUSE="cuda doc mpi opencl"
+
+RDEPEND=">=dev-libs/boost-1.48
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ mpi? ( || (
+ sys-cluster/openmpi[cxx]
+ sys-cluster/mpich2[cxx]
+ ) )
+ opencl? ( virtual/opencl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+
+
+# -D FEATURE_QT=false -D FEATURE_OPENCL=false -D FEATURE_CUDA=false mpi
+
+src_compile() {
+ cmake-utils_src_compile
+ if ( use doc); then
+ cmake-utils_src_compile doc
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc README
+ if ( use doc); then
+ dohtml doc/html/*
+ fi
+}
+