aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild12
-rw-r--r--sci-libs/dealii/metadata.xml2
2 files changed, 10 insertions, 4 deletions
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 00c2498d3..6992d107a 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,9 +34,9 @@ LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="
adolc assimp arpack cpu_flags_x86_avx cpu_flags_x86_sse2 cuda +debug
- doc +examples +gsl hdf5 +lapack metis mpi muparser nanoflann
- opencascade netcdf p4est petsc slepc +sparse static-libs sundials +tbb
- trilinos
+ doc +examples gmsh +gsl hdf5 +lapack metis mpi muparser nanoflann
+ opencascade netcdf p4est petsc scalapack slepc +sparse static-libs
+ sundials +tbb trilinos
"
# TODO: add slepc use flag once slepc is packaged for gentoo-science
@@ -52,6 +52,7 @@ RDEPEND="dev-libs/boost
arpack? ( sci-libs/arpack[mpi=] )
assimp? ( media-libs/assimp )
cuda? ( dev-util/nvidia-cuda-sdk )
+ gmsh? ( sci-libs/gmsh )
gsl? ( sci-libs/gsl )
hdf5? ( sci-libs/hdf5[mpi=] )
lapack? ( virtual/lapack )
@@ -63,6 +64,7 @@ RDEPEND="dev-libs/boost
opencascade? ( sci-libs/opencascade:* )
p4est? ( sci-libs/p4est[mpi] )
petsc? ( sci-mathematics/petsc[mpi=] )
+ scalapack? ( sci-libs/scalapack )
slepc? ( sci-mathematics/slepc[mpi=] )
sparse? ( sci-libs/umfpack )
sundials? ( sci-libs/sundials )
@@ -100,6 +102,7 @@ src_configure() {
-DDEAL_II_HAVE_SSE2="$(usex cpu_flags_x86_sse2)"
-DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
-DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
+ -DDEAL_II_WITH_GMSH="$(usex gmsh)"
-DDEAL_II_WITH_GSL="$(usex gsl)"
-DDEAL_II_WITH_HDF5="$(usex hdf5)"
-DDEAL_II_WITH_LAPACK="$(usex lapack)"
@@ -112,6 +115,7 @@ src_configure() {
-DDEAL_II_WITH_OPENCASCADE="$(usex opencascade)"
-DDEAL_II_WITH_P4EST="$(usex p4est)"
-DDEAL_II_WITH_PETSC="$(usex petsc)"
+ -DDEAL_II_WITH_SCALAPACK="$(usex scalapack)"
-DDEAL_II_WITH_SLEPC="$(usex slepc)"
-DDEAL_II_WITH_SUNDIALS="$(usex sundials)"
-DDEAL_II_WITH_UMFPACK="$(usex sparse)"
diff --git a/sci-libs/dealii/metadata.xml b/sci-libs/dealii/metadata.xml
index cc695c2b5..2125eb0c0 100644
--- a/sci-libs/dealii/metadata.xml
+++ b/sci-libs/dealii/metadata.xml
@@ -23,6 +23,7 @@ Build an additional debug library with extra debug codepaths, like asserts
and extra output. If you want to get meaningful backtraces see
&lt;http://www.gentoo.org/proj/en/qa/backtraces.xml&gt;</flag>
<flag name="c++11">Compile the library with -std=c++11</flag>
+ <flag name="gmsh">Add support for gmsh (<pkg>sci-libs/gmsh</pkg>)</flag>
<flag name="mesh_converter">Build and install the mesh_converter executable</flag>
<flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
<flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
@@ -32,6 +33,7 @@ and extra output. If you want to get meaningful backtraces see
<flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
<flag name="parameter_gui">Build and install the parameter_gui executable</flag>
<flag name="petsc">Add support for petsc (<pkg>sci-mathematics/petsc</pkg>)</flag>
+ <flag name="scalapack">Add support for ScaLAPACK (<pkg>sci-libs/scalapack</pkg>)</flag>
<flag name="slepc">Add support for slepc (<pkg>sci-mathematics/slepc</pkg>)</flag>
<flag name="sparse">Add support for suitesparse (<pkg>sci-libs/suitesparse</pkg>)</flag>
<flag name="tbb">Add threading support with the help of the tbb library (<pkg>dev-cpp/tbb</pkg>)</flag>