aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/zarja/Manifest1
-rw-r--r--sci-libs/zarja/zarja-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/zarja/Manifest b/sci-libs/zarja/Manifest
index 530a3371e..353c7aae0 100644
--- a/sci-libs/zarja/Manifest
+++ b/sci-libs/zarja/Manifest
@@ -1 +1,2 @@
DIST zarja-1.1.1.tar.gz 1368076 BLAKE2B 262d57285d4587df4bb64f2b690c015ce61f62e3bbe43756ef64f60f0a6d702573dc6e4eef1bd4fff137eb14446e3664296235d7d97866c9e38421bb4b2e73d2 SHA512 4618a4a558656b34025749e2f8b2dad8ee897dfb1eebfa4ac157b75f66d499d15d2d3a8a5e207aaa6aa9498c8d69e5a470875f1201be6056e7739f3b25dab06d
+DIST zarja-2.2.0.tar.gz 872503 BLAKE2B 26b0ef8ea36bda2af0173cc9a33e334219d9e87c4eafae4beaa31d235beb19da7594b7e504fa362fc1c37967f388b5c3523f8eba38ab5cb2b697d7220bf79754 SHA512 914ac12669e3597a354c48813014141a6070e5cbfea28a682ef85c8a5740069db025832944726ca3a65cff8e23939b1672177e9c68e1f3c579e5fb9e4bb8ec20
diff --git a/sci-libs/zarja/zarja-2.2.0.ebuild b/sci-libs/zarja/zarja-2.2.0.ebuild
new file mode 100644
index 000000000..405786ce7
--- /dev/null
+++ b/sci-libs/zarja/zarja-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Scientific multi-agent simulation library"
+HOMEPAGE="https://sourceforge.net/projects/zarja/"
+# latest version is binary only?
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-libs/gsl
+ virtual/lapack
+ sci-libs/fftw:3.0
+ dev-libs/boost
+ dev-cpp/tclap"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_install() {
+ cp -a "${S}"/* "${ED}" || die
+}